summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuke Arms2021-09-23 22:39:27 +1000
committerLuke Arms2021-09-23 22:39:27 +1000
commit598df5cc5f2a1d85718825e30b173da6d1205d1d (patch)
tree181a387d288f1c0a7c526d33a5712ab7ce64c211
parent2532fc188ae6837aa57d7d5e0741895db2616642 (diff)
downloadaur-598df5cc5f2a1d85718825e30b173da6d1205d1d.tar.gz
Update to v3.0.3
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD25
-rw-r--r--fix-relative-paths.patch18
-rw-r--r--setup.py1
5 files changed, 44 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 403708a56dcd..c340ecf5b91b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = emote
pkgdesc = Emoji Picker for Linux written in GTK3
- pkgver = 2.0.0
- pkgrel = 2
+ pkgver = 3.0.3
+ pkgrel = 1
url = https://github.com/tom-james-watson/Emote
arch = any
license = GPL3
@@ -11,15 +11,14 @@ pkgbase = emote
depends = gtk3
depends = python-gobject
depends = python-xlib
+ depends = python-manimpango
depends = libkeybinder3
- depends = emoji-font
depends = xdotool
- optdepends = noto-fonts-emoji: colour emoji
- optdepends = ttf-joypixels: colour emoji
+ source = https://github.com/tom-james-watson/Emote/archive/ff40e3d66b251aaf2e91116ba177e59f087e1021.tar.gz
source = setup.py
- source = https://github.com/tom-james-watson/Emote/archive/c6be700ab1af53ddd94d1935bc84e6c16fcdf931.tar.gz
- sha512sums = 83b6697b96882d3854c0f64a208571bfeec3e6324790e5508a6bd32092c5d462e86fa676c561111d98cce8058f1730303658612427b66daac086236e3e365316
+ source = fix-relative-paths.patch
sha512sums = SKIP
+ sha512sums = ef8caea8ad9e9bc0487dd8c816561027adda743c1e8e2779a64e7ae99fb227c820f31ef9c87fb910bae7a8ffc623e5e2e1a53a8c69ce0a35ad96557e97a5a949
+ sha512sums = 421f51590edcaa5c2143cc0ad3b8e29276219445365750ea359b36e4b1f1f8b48ccf85e966ba8a2d9166c74fdca3fbebf747e49498a1916c917149d0e68b6790
pkgname = emote
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..166fdb289a2f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!*.patch
+!*.py
diff --git a/PKGBUILD b/PKGBUILD
index fbfd89d84e1d..f69a5f7bffb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,24 @@
# Maintainer: Luke Arms <luke@arms.to>
pkgname=emote
-pkgver=2.0.0
-_pkgref=c6be700ab1af53ddd94d1935bc84e6c16fcdf931
-pkgrel=2
+pkgver=3.0.3
+_pkgref=ff40e3d66b251aaf2e91116ba177e59f087e1021
+pkgrel=1
url="https://github.com/tom-james-watson/Emote"
pkgdesc="Emoji Picker for Linux written in GTK3"
arch=('any')
license=('GPL3')
-depends=('python' 'gtk3' 'python-gobject' 'python-xlib' 'libkeybinder3' 'emoji-font' 'xdotool')
-optdepends=(
- 'noto-fonts-emoji: colour emoji'
- 'ttf-joypixels: colour emoji'
-)
+depends=('python' 'gtk3' 'python-gobject' 'python-xlib' 'python-manimpango' 'libkeybinder3' 'xdotool')
makedepends=('python-setuptools' 'python-pipenv')
source=(
- "setup.py"
"https://github.com/tom-james-watson/Emote/archive/${_pkgref}.tar.gz"
+ 'setup.py'
+ 'fix-relative-paths.patch'
)
sha512sums=(
- '83b6697b96882d3854c0f64a208571bfeec3e6324790e5508a6bd32092c5d462e86fa676c561111d98cce8058f1730303658612427b66daac086236e3e365316'
'SKIP'
+ 'ef8caea8ad9e9bc0487dd8c816561027adda743c1e8e2779a64e7ae99fb227c820f31ef9c87fb910bae7a8ffc623e5e2e1a53a8c69ce0a35ad96557e97a5a949'
+ '421f51590edcaa5c2143cc0ad3b8e29276219445365750ea359b36e4b1f1f8b48ccf85e966ba8a2d9166c74fdca3fbebf747e49498a1916c917149d0e68b6790'
)
build() {
@@ -29,9 +27,10 @@ build() {
# Move static files into the library
mv -T "$srcdir/Emote-$_pkgref/static" "$srcdir/Emote-$_pkgref/emote/static"
# Fix relative paths
- find "$srcdir/Emote-$_pkgref" -type f -name "*.py" -print0 |
- xargs -0 \
- sed -Ei 's/"static\/[^"]*"/os.path.join(os.path.dirname(__file__), &)/g'
+ #find "$srcdir/Emote-$_pkgref" -type f -name "*.py" -print0 |
+ # xargs -0 \
+ # sed -Ei 's/"static\/[^"]*"/os.path.join(os.path.dirname(__file__), &)/g'
+ patch -d "$srcdir/Emote-$_pkgref" -p1 <"$srcdir/fix-relative-paths.patch"
# Fix .desktop file
sed -Ei 's/\$\{SNAP\}//' "$srcdir/Emote-$_pkgref/snap/gui/emote.desktop"
# Fix version number
diff --git a/fix-relative-paths.patch b/fix-relative-paths.patch
new file mode 100644
index 000000000000..fdf03098dcc9
--- /dev/null
+++ b/fix-relative-paths.patch
@@ -0,0 +1,18 @@
+diff --git a/emote/__init__.py b/emote/__init__.py
+index 646bd85..e0a4ec4 100644
+--- a/emote/__init__.py
++++ b/emote/__init__.py
+@@ -1,3 +1,4 @@
++import os
+ import sys
+ import subprocess
+ import gi
+@@ -8,6 +9,8 @@ gi.require_version("Keybinder", "3.0")
+ from gi.repository import Gtk, Keybinder
+ from emote import picker, css, emojis, user_data, config
+
++os.chdir(os.path.dirname(__file__))
++
+ # Register updated emoji font
+ if config.is_snap:
+ manimpango.register_font(f"{config.snap_root}/static/NotoColorEmoji.ttf")
diff --git a/setup.py b/setup.py
index ca5177d7b558..b35a372c42a0 100644
--- a/setup.py
+++ b/setup.py
@@ -14,6 +14,7 @@ setup(
},
install_requires=[
"pygobject",
+ "manimpango"
],
package_data={
"emote": [