summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2014-05-26 11:52:51 -0500
committerDoug Newgard2014-05-26 11:52:51 -0500
commit28296ed42cbacc00e1f1f6a11561b08b29a620ef (patch)
treee0728c9f887179bdc4cd69c1b93c88cc3e4ab130
parent3610dbc5fac69b08bbb2c533bd7590653b041976 (diff)
downloadaur-28296ed42cbacc00e1f1f6a11561b08b29a620ef.tar.gz
Simpler text file installation
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a5347a6a13d..ef90701c450d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emotion_generic_players-git
pkgdesc = Emotion external binary executable players - Development version
- pkgver = 1.9.0alpha1.60.61b1da1
+ pkgver = 1.10.99.91.8001b50
pkgrel = 1
url = http://www.enlightenment.org
arch = i686
@@ -9,7 +9,7 @@ pkgbase = emotion_generic_players-git
makedepends = git
depends = efl-git
depends = vlc
- provides = emotion_generic_players=1.9.0alpha1.60.61b1da1
+ provides = emotion_generic_players=1.10.99.91.8001b50
conflicts = emotion_generic_players
options = debug
source = git://git.enlightenment.org/core/emotion_generic_players.git
diff --git a/PKGBUILD b/PKGBUILD
index 4f59ea651c75..b788ffe47d68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=emotion_generic_players
pkgname=$_pkgname-git
-pkgver=1.9.0alpha1.60.61b1da1
+pkgver=1.10.99.91.8001b50
pkgrel=1
pkgdesc="Emotion external binary executable players - Development version"
arch=('i686' 'x86_64')
@@ -43,14 +43,13 @@ build() {
package(){
cd "$srcdir/$_pkgname"
- make DESTDIR="$pkgdir" install
+ make -j1 DESTDIR="$pkgdir" install
# install text files
- install -Dm644 ChangeLog "$pkgdir/usr/share/doc/$_pkgname/ChangeLog"
- install -Dm644 NEWS "$pkgdir/usr/share/doc/$_pkgname/NEWS"
- install -Dm644 README "$pkgdir/usr/share/doc/$_pkgname/README"
+ install -d "$pkgdir/usr/share/doc/$_pkgname/"
+ install -m644 -t "$pkgdir/usr/share/doc/$_pkgname/" ChangeLog NEWS README
# install license files
- install -Dm644 AUTHORS "$pkgdir/usr/share/licenses/$pkgname/AUTHORS"
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ install -m644 -t "$pkgdir/usr/share/licenses/$pkgname/" AUTHORS COPYING
}