summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbinex-dsk2021-03-12 11:26:40 -0500
committerbinex-dsk2021-03-12 11:26:40 -0500
commitad5e321139d90b0a922c30b3bf28f218c48ef859 (patch)
tree69f4607e61d8dceb2193321115a9a05bcd60e150
downloadaur-ad5e321139d90b0a922c30b3bf28f218c48ef859.tar.gz
initial
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
-rwxr-xr-xemptty.initd7
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..67f1d2f6d423
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = emptty-openrc
+ pkgdesc = OpenRC emptty init script
+ pkgver = 20210312
+ pkgrel = 1
+ url = https://github.com/tvrzna/emptty
+ arch = any
+ license = MIT
+ provides = emptty-openrc
+ source = emptty.initd
+ sha256sums = 05ab1fd1fc81d27a07240fe942e2724351314afb4b9a0ee594c0f38cad6cdfac
+
+pkgname = emptty-openrc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b9c316e7b29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Carson Rueter <roachh at proton mail dot com>
+
+pkgname=emptty-openrc
+pkgver=20210312
+pkgrel=1
+pkgdesc="OpenRC emptty init script"
+arch=('any')
+url="https://github.com/tvrzna/emptty"
+license=('MIT')
+provides=('emptty-openrc')
+source=("emptty.initd")
+sha256sums=('05ab1fd1fc81d27a07240fe942e2724351314afb4b9a0ee594c0f38cad6cdfac')
+
+pkgver() {
+ date +%Y%m%d
+}
+
+_inst_initd(){
+ install -Dm755 ${srcdir}/$1.initd ${pkgdir}/etc/init.d/$1
+
+ sed -e 's|#!/sbin/openrc-run|#!/usr/bin/openrc-run|g' \
+ -e 's|/var/run|/run|g' \
+ -e 's|/usr/sbin|/usr/bin|g' \
+ -i ${pkgdir}/etc/init.d/$1
+}
+
+package(){
+ _inst_initd 'emptty'
+}
diff --git a/emptty.initd b/emptty.initd
new file mode 100755
index 000000000000..b81ff2a12e6a
--- /dev/null
+++ b/emptty.initd
@@ -0,0 +1,7 @@
+#!/sbin/openrc-run
+supervisor=supervise-daemon
+description="emptty Display Manager"
+command=/usr/bin/emptty
+command_args="-d"
+pidfile="/run/${RC_SVCNAME}.pid"
+respawn_period=${respawn_period-60}