summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMewp2016-05-13 18:16:17 +0200
committermewp2016-05-13 18:22:39 +0200
commit06e9b450050ee932e4a10ff39f82d38cf428cef5 (patch)
treee02194d4b370e07785d1cf38f069fb29cedb1b00
downloadaur-06e9b450050ee932e4a10ff39f82d38cf428cef5.tar.gz
Initial commit.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
-rw-r--r--fixed-version.patch16
-rw-r--r--fixes-for-gcc-6.1.1.patch21
4 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7700fda5653
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = emptyepsilon
+ pkgdesc = Open source spaceship bridge simulator
+ pkgver = 2016.05.07
+ pkgrel = 1
+ url = https://github.com/daid/EmptyEpsilon
+ arch = x86
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ makedepends = git
+ makedepends = mesa
+ depends = sfml
+ source = git+https://github.com/daid/EmptyEpsilon.git#tag=EE-2016.05.07
+ source = git+https://github.com/daid/SeriousProton.git#tag=EE-2016.05.07
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = emptyepsilon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2598d985179e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Mewp <aur.archlinux.org@mewp.pl>
+pkgname=emptyepsilon
+pkgver=2016.05.07
+pkgrel=1
+epoch=
+pkgdesc="Open source spaceship bridge simulator"
+arch=('x86' 'x86_64')
+url="https://github.com/daid/EmptyEpsilon"
+license=('GPL2')
+groups=()
+depends=('sfml')
+makedepends=('cmake' 'git' 'mesa')
+source=("git+https://github.com/daid/EmptyEpsilon.git#tag=EE-2016.05.07"
+ "git+https://github.com/daid/SeriousProton.git#tag=EE-2016.05.07")
+sha256sums=('SKIP' 'SKIP')
+
+build() {
+ cd $srcdir/EmptyEpsilon/
+ cmake -DSERIOUS_PROTON_DIR=../SeriousProton/ \
+ -DCMAKE_CXX_FLAGS='-DINSTALL_PREFIX=\"/usr\"' \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ .
+ make
+}
+
+prepare() {
+ patch -Np1 < ../fixes-for-gcc-6.1.1.patch
+ patch -Np1 < ../fixed-version.patch
+}
+
+package() {
+ cd $srcdir/EmptyEpsilon
+ make DESTDIR="$pkgdir/" install
+}
+
diff --git a/fixed-version.patch b/fixed-version.patch
new file mode 100644
index 000000000000..a3d61afb37a0
--- /dev/null
+++ b/fixed-version.patch
@@ -0,0 +1,16 @@
+diff -aur src/EmptyEpsilon/CMakeLists.txt src.patched/EmptyEpsilon/CMakeLists.txt
+--- src/EmptyEpsilon/CMakeLists.txt 2016-05-13 17:57:56.070000246 +0200
++++ src.patched/EmptyEpsilon/CMakeLists.txt 2016-05-13 18:06:00.526668550 +0200
+@@ -8,9 +8,9 @@
+ message(FATAL_ERROR "SERIOUS_PROTON_DIR was not set. Unable to continue")
+ endif(NOT DEFINED SERIOUS_PROTON_DIR)
+
+-string(TIMESTAMP CPACK_PACKAGE_VERSION_MAJOR "%Y")
+-string(TIMESTAMP CPACK_PACKAGE_VERSION_MINOR "%m")
+-string(TIMESTAMP CPACK_PACKAGE_VERSION_PATCH "%d")
++string(TIMESTAMP CPACK_PACKAGE_VERSION_MAJOR "2016")
++string(TIMESTAMP CPACK_PACKAGE_VERSION_MINOR "05")
++string(TIMESTAMP CPACK_PACKAGE_VERSION_PATCH "07")
+
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")
diff --git a/fixes-for-gcc-6.1.1.patch b/fixes-for-gcc-6.1.1.patch
new file mode 100644
index 000000000000..32afd6099f51
--- /dev/null
+++ b/fixes-for-gcc-6.1.1.patch
@@ -0,0 +1,21 @@
+diff -aur src/EmptyEpsilon/src/spaceObjects/spaceship.cpp src.patched/EmptyEpsilon/src/spaceObjects/spaceship.cpp
+--- src/EmptyEpsilon/src/spaceObjects/spaceship.cpp 2016-05-13 17:57:56.566666915 +0200
++++ src.patched/EmptyEpsilon/src/spaceObjects/spaceship.cpp 2016-05-13 17:59:01.846667135 +0200
+@@ -554,7 +554,7 @@
+ weapon_tube[n].update(delta);
+ }
+
+- model_info.engine_scale = std::min(1.0, std::max(fabs(getAngularVelocity() / turn_speed), fabs(current_impulse)));
++ model_info.engine_scale = std::min(1.0f, std::max(fabs(getAngularVelocity() / turn_speed), fabs(current_impulse)));
+ if (has_jump_drive && jump_delay > 0.0f)
+ model_info.warp_scale = (10.0f - jump_delay) / 10.0f;
+ else
+diff -aur src/SeriousProton/src/networkRecorder.cpp src.patched/SeriousProton/src/networkRecorder.cpp
+--- src/SeriousProton/src/networkRecorder.cpp 2016-05-13 10:25:07.899749832 +0200
++++ src.patched/SeriousProton/src/networkRecorder.cpp 2016-05-13 17:58:19.280000325 +0200
+@@ -1,4 +1,5 @@
+ #include <string.h>
++#include <math.h>
+
+ #include "networkRecorder.h"
+ #include "multiplayer.h"