summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMewp2016-05-26 10:23:18 +0200
committerMewp2016-05-26 10:23:18 +0200
commitc716800eb3a705a89ca95df4aad989d3dc7b4ad2 (patch)
tree697ed7354cf241a7d532ac890c5b4ec7abc84e34
parent06e9b450050ee932e4a10ff39f82d38cf428cef5 (diff)
downloadaur-c716800eb3a705a89ca95df4aad989d3dc7b4ad2.tar.gz
Update to version 2015-05-22
-rw-r--r--PKGBUILD7
-rw-r--r--fixed-version.patch2
-rw-r--r--fixes-for-gcc-6.1.1.patch21
3 files changed, 4 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2598d985179e..53fe8417be47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Mewp <aur.archlinux.org@mewp.pl>
pkgname=emptyepsilon
-pkgver=2016.05.07
+pkgver=2016.05.22
pkgrel=1
epoch=
pkgdesc="Open source spaceship bridge simulator"
@@ -10,8 +10,8 @@ license=('GPL2')
groups=()
depends=('sfml')
makedepends=('cmake' 'git' 'mesa')
-source=("git+https://github.com/daid/EmptyEpsilon.git#tag=EE-2016.05.07"
- "git+https://github.com/daid/SeriousProton.git#tag=EE-2016.05.07")
+source=("git+https://github.com/daid/EmptyEpsilon.git#tag=EE-2016.05.22"
+ "git+https://github.com/daid/SeriousProton.git#tag=EE-2016.05.22")
sha256sums=('SKIP' 'SKIP')
build() {
@@ -24,7 +24,6 @@ build() {
}
prepare() {
- patch -Np1 < ../fixes-for-gcc-6.1.1.patch
patch -Np1 < ../fixed-version.patch
}
diff --git a/fixed-version.patch b/fixed-version.patch
index a3d61afb37a0..87646636b7bf 100644
--- a/fixed-version.patch
+++ b/fixed-version.patch
@@ -10,7 +10,7 @@ diff -aur src/EmptyEpsilon/CMakeLists.txt src.patched/EmptyEpsilon/CMakeLists.tx
-string(TIMESTAMP CPACK_PACKAGE_VERSION_PATCH "%d")
+string(TIMESTAMP CPACK_PACKAGE_VERSION_MAJOR "2016")
+string(TIMESTAMP CPACK_PACKAGE_VERSION_MINOR "05")
-+string(TIMESTAMP CPACK_PACKAGE_VERSION_PATCH "07")
++string(TIMESTAMP CPACK_PACKAGE_VERSION_PATCH "22")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")
diff --git a/fixes-for-gcc-6.1.1.patch b/fixes-for-gcc-6.1.1.patch
deleted file mode 100644
index 32afd6099f51..000000000000
--- a/fixes-for-gcc-6.1.1.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -aur src/EmptyEpsilon/src/spaceObjects/spaceship.cpp src.patched/EmptyEpsilon/src/spaceObjects/spaceship.cpp
---- src/EmptyEpsilon/src/spaceObjects/spaceship.cpp 2016-05-13 17:57:56.566666915 +0200
-+++ src.patched/EmptyEpsilon/src/spaceObjects/spaceship.cpp 2016-05-13 17:59:01.846667135 +0200
-@@ -554,7 +554,7 @@
- weapon_tube[n].update(delta);
- }
-
-- model_info.engine_scale = std::min(1.0, std::max(fabs(getAngularVelocity() / turn_speed), fabs(current_impulse)));
-+ model_info.engine_scale = std::min(1.0f, std::max(fabs(getAngularVelocity() / turn_speed), fabs(current_impulse)));
- if (has_jump_drive && jump_delay > 0.0f)
- model_info.warp_scale = (10.0f - jump_delay) / 10.0f;
- else
-diff -aur src/SeriousProton/src/networkRecorder.cpp src.patched/SeriousProton/src/networkRecorder.cpp
---- src/SeriousProton/src/networkRecorder.cpp 2016-05-13 10:25:07.899749832 +0200
-+++ src.patched/SeriousProton/src/networkRecorder.cpp 2016-05-13 17:58:19.280000325 +0200
-@@ -1,4 +1,5 @@
- #include <string.h>
-+#include <math.h>
-
- #include "networkRecorder.h"
- #include "multiplayer.h"