summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander2023-09-05 08:22:26 +0300
committerAlexander2023-09-05 08:22:26 +0300
commitc37df0099ba14e5db7b2be183951b1d3c7e87f6f (patch)
tree6d9730ce00f7f220c32f599acd0c9f444ce9a0d2
downloadaur-c37df0099ba14e5db7b2be183951b1d3c7e87f6f.tar.gz
First commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD46
-rw-r--r--cstdint.patch41
-rw-r--r--shortcut.desktop9
4 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2af6ad2c76d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emu80-qt
+ pkgdesc = Emulator for bunch of Soviet PCs
+ pkgver = 4.0.444
+ pkgrel = 1
+ url = https://emu80.org/
+ arch = x86_64
+ license = GPL3
+ depends = qt5-base
+ source = https://github.com/vpyk/emu80v4/archive/refs/tags/v4.0.444.tar.gz
+ source = cstdint.patch
+ source = shortcut.desktop
+ sha256sums = f3a9488242804b4d5e39d6c63b2cba7abff9723d831f66f342c5c0de574a8c37
+ sha256sums = a32506b1ac786a058044e178961456c4bdee0eec87f81b679deb25c0fb7e2bab
+ sha256sums = bd817f4c7a0183e322fb25fa27160f5279ac0310ea8445a86edd9c944b43e839
+
+pkgname = emu80-qt
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33db22d0c8bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Alexander Aleschenko <alex.aleschenko@gmail.com>
+
+pkgname=emu80-qt
+pkgver=4.0.444
+pkgrel=1
+pkgdesc="Emulator for bunch of Soviet PCs"
+arch=('x86_64')
+url="https://emu80.org/"
+license=("GPL3")
+depends=("qt5-base")
+source=("https://github.com/vpyk/emu80v4/archive/refs/tags/v${pkgver}.tar.gz" "cstdint.patch" "shortcut.desktop")
+sha256sums=("f3a9488242804b4d5e39d6c63b2cba7abff9723d831f66f342c5c0de574a8c37" "a32506b1ac786a058044e178961456c4bdee0eec87f81b679deb25c0fb7e2bab" "bd817f4c7a0183e322fb25fa27160f5279ac0310ea8445a86edd9c944b43e839")
+
+prepare() {
+ cd ${srcdir}/emu80v4-${pkgver}
+ dos2unix src/Cpu8080dasm.cpp
+ dos2unix src/EmuObjects.h
+ dos2unix src/EmuTypes.h
+ patch --forward --strip=1 --input="${srcdir}/cstdint.patch"
+ unix2dos src/EmuObjects.h
+ unix2dos src/Cpu8080dasm.cpp
+ unix2dos src/EmuTypes.h
+}
+
+build() {
+ cd "emu80v4-${pkgver}"
+ qmake src/Emu80qt.pro
+ make
+}
+
+package() {
+ cd "emu80v4-${pkgver}"
+ destination=${pkgdir}/opt/${pkgname}
+
+ install -d -m755 ${destination}
+ cp -r dist/* ${destination}
+ cp COPYING.txt ${destination}
+ cp whatsnew.txt ${destination}
+ cp doc/* ${destination}
+ install -m0755 Emu80qt ${destination}/${pkgname}
+
+ install -d -m755 ${pkgdir}/usr/bin
+ ln -s "/opt/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m644 "${srcdir}/shortcut.desktop" "${pkgdir}/usr/share/applications/emu80-qt.desktop"
+ install -D -m644 "src/qt/icons/emu80.png" "${pkgdir}/usr/share/pixmaps/emu80.png"
+}
diff --git a/cstdint.patch b/cstdint.patch
new file mode 100644
index 000000000000..4be6ccd61d67
--- /dev/null
+++ b/cstdint.patch
@@ -0,0 +1,41 @@
+diff --git a/src/Cpu8080dasm.cpp b/src/Cpu8080dasm.cpp
+index 910e668..0d039e4 100644
+--- a/src/Cpu8080dasm.cpp
++++ b/src/Cpu8080dasm.cpp
+@@ -19,6 +19,7 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#include <cstdint>
+ #include <string>
+ #include <sstream>
+ #include <iomanip>
+diff --git a/src/EmuObjects.h b/src/EmuObjects.h
+index 8166920..fbf4251 100644
+--- a/src/EmuObjects.h
++++ b/src/EmuObjects.h
+@@ -19,13 +19,13 @@
+ #ifndef EMUOBJECTS_H
+ #define EMUOBJECTS_H
+
++#include <cstdint>
+ #include <vector>
+ #include <list>
+ #include <string>
+
+ #include "Parameters.h"
+
+-
+ class Platform;
+
+ class EmuObject
+diff --git a/src/EmuTypes.h b/src/EmuTypes.h
+index 9c601c5..18f62c8 100644
+--- a/src/EmuTypes.h
++++ b/src/EmuTypes.h
+@@ -19,6 +19,7 @@
+ #ifndef EMUTYPES_H
+ #define EMUTYPES_H
+
++#include <cstdint>
+ #include <string>
diff --git a/shortcut.desktop b/shortcut.desktop
new file mode 100644
index 000000000000..6526b08f5fec
--- /dev/null
+++ b/shortcut.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Emu80-qt
+Comment=Emulator for bunch of Soviet PCs
+GenericName=Emulator
+Exec=/usr/bin/emu80-qt
+Type=Application
+Icon=emu80
+Categories=Utility;Development;Emulator;
+Keywords=emu80;