summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Jaksch2018-02-27 17:08:09 +0100
committerOliver Jaksch2018-02-27 17:08:09 +0100
commit962d89fcdb9af4244b7adbb35119dc28e6848bd6 (patch)
treedcd8273e063e376903e1c473f05ae3339a34f744
parent6f191b11f1cffb3be22ec5f0550b81f485df02f6 (diff)
downloadaur-962d89fcdb9af4244b7adbb35119dc28e6848bd6.tar.gz
Update and switching to RELEASE
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c533e114d1a..076b1ee6a1e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Sep 22 09:43:19 UTC 2017
+# Tue Feb 27 16:08:09 UTC 2018
pkgbase = emulationstation-autoscraper
pkgdesc = An auto-scraper for EmulationStation written in Go using hashes
- pkgver = 273.ca24b2b
+ pkgver = 1.4.5
pkgrel = 1
url = https://github.com/sselph/scraper
arch = i686
@@ -13,8 +13,8 @@ pkgbase = emulationstation-autoscraper
license = custom
makedepends = git
makedepends = go
- source = https://raw.githubusercontent.com/sselph/scraper/master/LICENSE
- sha256sums = SKIP
+ source = https://github.com/sselph/scraper/archive/v1.4.5.tar.gz
+ sha256sums = 5e7496b7634126f5be81fdd88a20fe108f40d4a8a0089b2d07ae82ea2cea812c
pkgname = emulationstation-autoscraper
diff --git a/PKGBUILD b/PKGBUILD
index 9bc47ba00b5c..45a3ea0bf220 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Oliver Jaksch <arch-aur@com-in.de>
pkgname=emulationstation-autoscraper
-pkgver=273.ca24b2b
+pkgver=1.4.5
pkgrel=1
pkgdesc="An auto-scraper for EmulationStation written in Go using hashes"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
@@ -9,22 +9,24 @@ url="https://github.com/sselph/scraper"
license=('custom')
makedepends=('git' 'go')
-source=("https://raw.githubusercontent.com/sselph/scraper/master/LICENSE")
-sha256sums=('SKIP')
+source=("https://github.com/sselph/scraper/archive/v${pkgver}.tar.gz")
+sha256sums=('5e7496b7634126f5be81fdd88a20fe108f40d4a8a0089b2d07ae82ea2cea812c')
+
+scraperdir="scraper-${pkgver}"
build() {
- cd "${srcdir}"
- export GOPATH="${srcdir}"
- echo $(go get github.com/sselph/scraper)
+ cd "${srcdir}/${scraperdir}"
+ echo $arch
echo $(go build github.com/sselph/scraper)
}
package() {
- strip "${srcdir}/scraper"
- install -Dm755 "${srcdir}/scraper" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 "${srcdir}/src/github.com/sselph/scraper/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
- for LIC in $(find ./src/github.com/sselph/scraper/vendor/github.com -name LICENSE); do
+ cd "${srcdir}/${scraperdir}"
+ strip "scraper"
+ install -Dm755 "${srcdir}/${scraperdir}/scraper" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${srcdir}/${scraperdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
+ for LIC in $(find vendor/github.com -name LICENSE); do
PKGNAME="$(echo ${LIC} | awk -F "/" '{print $(NF-1)}')"
- install -Dm644 "${srcdir}/${LIC}" "${pkgdir}/usr/share/licenses/${pkgname}/license.${PKGNAME}"
+ install -Dm644 "${srcdir}/${scraperdir}/${LIC}" "${pkgdir}/usr/share/licenses/${pkgname}/license.${PKGNAME}"
done
}