summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Styhre2021-12-29 14:19:40 +0100
committerLeon Styhre2021-12-29 14:19:40 +0100
commit79c782d6a58a056774b1fc3dc47dfbdea3e61946 (patch)
treeea7ec2bf4a11fa015cd7de38ae95b673b346a828
downloadaur-79c782d6a58a056774b1fc3dc47dfbdea3e61946.tar.gz
Initial commit for release 1.2.0
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD23
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b25411fd2cc1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = emulationstation-de
+ pkgdesc = EmulationStation Desktop Edition (ES-DE) is a frontend for browsing and launching games from your multi-platform game collection
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://es-de.org
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = curl
+ makedepends = pkgconf
+ makedepends = make
+ makedepends = ffmpeg
+ makedepends = freeimage
+ makedepends = freetype2
+ makedepends = pugixml
+ makedepends = sdl2
+ depends = curl
+ depends = ffmpeg
+ depends = freeimage
+ depends = freetype2
+ depends = pugixml
+ depends = sdl2
+ conflicts = emulationstation
+ conflicts = emulationstation-git
+ source = https://gitlab.com/leonstyhre/emulationstation-de/-/archive/stable-1.2/emulationstation-de-stable-1.2.tar.gz
+ md5sums = b32c55fd0a19fbc919e58b3e20cdcda1
+
+pkgname = emulationstation-de
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..761a5c031d4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Leon Styhre <info@es-de.org>
+
+pkgname=emulationstation-de
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="EmulationStation Desktop Edition (ES-DE) is a frontend for browsing and launching games from your multi-platform game collection"
+arch=('x86_64')
+url="https://es-de.org"
+license=('MIT')
+depends=('curl' 'ffmpeg' 'freeimage' 'freetype2' 'pugixml' 'sdl2')
+makedepends=('cmake' 'curl' 'pkgconf' 'make' 'ffmpeg' 'freeimage' 'freetype2' 'pugixml' 'sdl2')
+conflicts=('emulationstation' 'emulationstation-git')
+source=("https://gitlab.com/leonstyhre/emulationstation-de/-/archive/stable-1.2/emulationstation-de-stable-1.2.tar.gz")
+md5sums=('b32c55fd0a19fbc919e58b3e20cdcda1')
+
+build() {
+ cmake -B emulationstation-de-stable-1.2 -S emulationstation-de-stable-1.2 .
+ make -C emulationstation-de-stable-1.2 -j4
+}
+
+package() {
+ make -C emulationstation-de-stable-1.2 DESTDIR="${pkgdir}" install
+}