summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Styhre2023-07-13 22:44:20 +0200
committerLeon Styhre2023-07-13 22:44:20 +0200
commita6b81a910d45aaa0aaed8cc668cd031159c36532 (patch)
treef3c9e41e149382f3004ca74cfbae5c3fa270406b
parent66f05cf88b5af50488ec3cfc7d2bce52d2fe7fc5 (diff)
downloadaur-a6b81a910d45aaa0aaed8cc668cd031159c36532.tar.gz
Updated for the 2.1.0 release
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08340343202d..7d4ba7d41467 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = emulationstation-de
pkgdesc = EmulationStation Desktop Edition (ES-DE) is a frontend for browsing and launching games from your multi-platform game collection
- pkgver = 2.0.1
- pkgrel = 2
+ pkgver = 2.1.0
+ pkgrel = 1
url = https://es-de.org
arch = x86_64
license = MIT
@@ -13,6 +13,7 @@ pkgbase = emulationstation-de
makedepends = freeimage
makedepends = freetype2
makedepends = libgit2
+ makedepends = poppler
makedepends = pugixml
makedepends = sdl2
depends = curl
@@ -20,11 +21,12 @@ pkgbase = emulationstation-de
depends = freeimage
depends = freetype2
depends = libgit2
+ depends = poppler
depends = pugixml
depends = sdl2
conflicts = emulationstation
conflicts = emulationstation-git
- source = emulationstation-de-stable-2.0-AUR_2.0.1-2.tar.gz::https://gitlab.com/es-de/emulationstation-de/-/archive/stable-2.0-AUR/emulationstation-de-stable-2.0-AUR.tar.gz
- md5sums = f99241386f267ba04a23cf5a9a542e0c
+ source = emulationstation-de-stable-2.1-AUR_2.1.0-1.tar.gz::https://gitlab.com/es-de/emulationstation-de/-/archive/stable-2.1-AUR/emulationstation-de-stable-2.1-AUR.tar.gz
+ md5sums = 318b6efea614e549cd1cb1f071a84adf
pkgname = emulationstation-de
diff --git a/PKGBUILD b/PKGBUILD
index 10668a12593d..cb83dcba0f8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer: Leon Styhre <info@es-de.org>
pkgname=emulationstation-de
-pkgver=2.0.1
-pkgrel=2
+pkgver=2.1.0
+pkgrel=1
pkgdesc="EmulationStation Desktop Edition (ES-DE) is a frontend for browsing and launching games from your multi-platform game collection"
arch=('x86_64')
url="https://es-de.org"
license=('MIT')
-depends=('curl' 'ffmpeg' 'freeimage' 'freetype2' 'libgit2' 'pugixml' 'sdl2')
-makedepends=('cmake' 'curl' 'pkgconf' 'make' 'ffmpeg' 'freeimage' 'freetype2' 'libgit2' 'pugixml' 'sdl2')
+depends=('curl' 'ffmpeg' 'freeimage' 'freetype2' 'libgit2' 'poppler' 'pugixml' 'sdl2')
+makedepends=('cmake' 'curl' 'pkgconf' 'make' 'ffmpeg' 'freeimage' 'freetype2' 'libgit2' 'poppler' 'pugixml' 'sdl2')
conflicts=('emulationstation' 'emulationstation-git')
-source=("emulationstation-de-stable-2.0-AUR_${pkgver}-${pkgrel}.tar.gz::https://gitlab.com/es-de/emulationstation-de/-/archive/stable-2.0-AUR/emulationstation-de-stable-2.0-AUR.tar.gz")
-md5sums=('f99241386f267ba04a23cf5a9a542e0c')
+source=("emulationstation-de-stable-2.1-AUR_${pkgver}-${pkgrel}.tar.gz::https://gitlab.com/es-de/emulationstation-de/-/archive/stable-2.1-AUR/emulationstation-de-stable-2.1-AUR.tar.gz")
+md5sums=('318b6efea614e549cd1cb1f071a84adf')
build() {
- cmake -DAUR_BUILD=on -B emulationstation-de-stable-2.0-AUR -S emulationstation-de-stable-2.0-AUR
- make -C emulationstation-de-stable-2.0-AUR -j4
+ cmake -DAUR_BUILD=on -B emulationstation-de-stable-2.1-AUR -S emulationstation-de-stable-2.1-AUR
+ make -C emulationstation-de-stable-2.1-AUR -j4
}
package() {
- make -C emulationstation-de-stable-2.0-AUR DESTDIR="${pkgdir}" install
+ make -C emulationstation-de-stable-2.1-AUR DESTDIR="${pkgdir}" install
}