summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Riedel2021-02-02 00:59:53 +0100
committerSebastian Riedel2021-02-02 00:59:53 +0100
commitc1dce6430de678d83b14c48e6ca8981c6542d5f0 (patch)
tree426d7c681f5ecee1f700cd61809ebf40b763a14f
downloadaur-c1dce6430de678d83b14c48e6ca8981c6542d5f0.tar.gz
Initial version 2021.01.30
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
-rw-r--r--emulicious.desktop14
-rw-r--r--emulicious.sh2
4 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b901ab3bbde7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = emulicious-bin
+ pkgdesc = Game Boy, Game Boy Color, Master System, Game Gear and MSX emulator with C-level debug capabilties
+ pkgver = 2021.01.30
+ pkgrel = 1
+ url = https://emulicious.net
+ arch = any
+ license = custom,
+ license = BSD
+ depends = java-environment
+ source = emulicious-bin-2021.01.30.zip::https://emulicious.net/download/emulicious/?wpdmdl=205
+ source = emulicious.sh
+ source = emulicious.desktop
+ sha256sums = fbe0ac99dae07c19123ecfacca6100a1dc97a9344133a3caa9ab75616892100f
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = emulicious-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9d7c12824fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: basxto <archlinux basxto de>
+
+pkgname=emulicious-bin
+# for release date see WhatsNew.txt
+# emulicious does not communicate any version numbers
+pkgver=2021.01.30
+pkgrel=1
+pkgdesc="Game Boy, Game Boy Color, Master System, Game Gear and MSX emulator with C-level debug capabilties"
+url="https://emulicious.net"
+license=('custom', 'BSD')
+arch=('any')
+depends=('java-environment')
+source=("$pkgname-$pkgver.zip::https://emulicious.net/download/emulicious/?wpdmdl=205" "emulicious.sh" "emulicious.desktop")
+sha256sums=('fbe0ac99dae07c19123ecfacca6100a1dc97a9344133a3caa9ab75616892100f' 'SKIP' 'SKIP')
+
+package() {
+ # get new release ready
+ #grep "^[0-9]\{4\}-[0-9]\{2\}-[0-9]\{2\}" ${srcdir}/WhatsNew.txt | head -1 | tr - .
+ #sha256sum ${srcdir}/$pkgname-$pkgver.zip
+ #makepkg --printsrcinfo > .SRCINFO
+
+ mkdir -p ${pkgdir}/usr/share/$pkgname/ ${pkgdir}/etc/
+ install -Dm644 ${srcdir}/License.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 ${srcdir}/LICENSE-JInput.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE-JInput"
+ cp -r ${srcdir}/Highlighters/ ${srcdir}/MSX/ ${srcdir}/KeyPresets/ ${pkgdir}/usr/share/$pkgname/
+ install -Dm644 ${srcdir}/Emulicious.jar ${srcdir}/WhatsNew.txt ${srcdir}/Expressions.txt ${srcdir}/ReadMe.txt ${srcdir}/*.ports ${pkgdir}/usr/share/$pkgname/
+ install -Dm755 ${srcdir}/emulicious.sh ${pkgdir}/usr/bin/emulicious
+ install -Dm644 ${srcdir}/emulicious.desktop ${pkgdir}/usr/share/applications/emulicious.desktop
+}
diff --git a/emulicious.desktop b/emulicious.desktop
new file mode 100644
index 000000000000..603800c62f4d
--- /dev/null
+++ b/emulicious.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Version=1.0
+Name=Emulicious
+GenericName=Emulator
+Comment=Game Boy, Game Boy Color, Master System, Game Gear and MSX emulator
+Comment[de]=Game Boy, Game Boy Color, Master System, Game Gear und MSX-Emulator
+
+TryExec=java
+Exec=emulicious
+Terminal=false
+
+Categories=Game;Emulator;Development;Debugger;Java \ No newline at end of file
diff --git a/emulicious.sh b/emulicious.sh
new file mode 100644
index 000000000000..da0f30737a38
--- /dev/null
+++ b/emulicious.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+java -jar /usr/share/emulicious-bin/Emulicious.jar "$@" \ No newline at end of file