summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2023-11-26 12:26:15 +0100
committerbegin-theadventure2023-11-26 12:26:15 +0100
commita11fe59b8773e1b883534bc2ba929fc11fa91308 (patch)
tree1d490da3c824b6d4875eff012868de3c740ae268
parent6b77f3560e95ff7b8232b3bff92dacfc609d7d75 (diff)
downloadaur-emulsion-bin.tar.gz
10.4, cleanup
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE.md21
-rw-r--r--PKGBUILD30
3 files changed, 21 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53c5e409aaa9..457dc7272be3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = emulsion-bin
pkgdesc = A fast and minimalistic image viewer (binary release)
- pkgver = 9.0
- pkgrel = 3
- url = https://arturkovacs.github.io/emulsion-website
+ pkgver = 10.4
+ pkgrel = 1
+ url = https://github.com/ArturKovacs/emulsion
arch = x86_64
license = MIT
- depends = gcc-libs
- optdepends = hicolor-icon-theme
+ depends = hicolor-icon-theme
+ depends = libavif
provides = emulsion
conflicts = emulsion
- options = !emptydirs
- source = emulsion-9.0.deb::https://github.com/arturkovacs/emulsion/releases/download/v9.0/Emulsion-Linux.deb-v9.0.deb
- sha256sums = f66ab3b655af4da6e4c3fb60540c241cc9e7055ab70a0638aedd8af484d90427
+ source = https://github.com/ArturKovacs/emulsion/releases/download/v10.4/Emulsion-Linux.deb-v10.4.deb
+ sha256sums = 823fde86860ded2335c59114fc377fc02d14738ba5c1040cce54c501f5516a3f
pkgname = emulsion-bin
-
diff --git a/LICENSE.md b/LICENSE.md
deleted file mode 100644
index 74e2787c5da8..000000000000
--- a/LICENSE.md
+++ /dev/null
@@ -1,21 +0,0 @@
-# The MIT License
-
-Copyright © 2020 Hoàng Văn Khải
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in all
-copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index afc5bd976782..7e6efb13380d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,23 @@
-# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
+# Contributor: Luis Martinez <luis dot martinez at tuta dot io>
# Contributor: Szymon Scholz <first name last name [at] gmail [dot] com>
pkgname=emulsion-bin
-_name="${pkgname%-bin}"
-pkgver=9.0
-pkgrel=3
+pkgver=10.4
+pkgrel=1
pkgdesc="A fast and minimalistic image viewer (binary release)"
+url="https://github.com/ArturKovacs/emulsion"
arch=('x86_64')
-url="https://arturkovacs.github.io/emulsion-website"
license=('MIT')
-depends=('gcc-libs')
-optdepends=('hicolor-icon-theme')
-provides=("$_name")
-conflicts=("$_name")
-options=(!emptydirs)
-source=("$_name-$pkgver.deb::https://github.com/arturkovacs/emulsion/releases/download/v$pkgver/Emulsion-Linux.deb-v$pkgver.deb")
-sha256sums=('f66ab3b655af4da6e4c3fb60540c241cc9e7055ab70a0638aedd8af484d90427')
+depends=('hicolor-icon-theme' 'libavif')
+provides=("emulsion")
+conflicts=("emulsion")
+source=("$url/releases/download/v$pkgver/Emulsion-Linux.deb-v$pkgver.deb")
+sha256sums=('823fde86860ded2335c59114fc377fc02d14738ba5c1040cce54c501f5516a3f')
package() {
- tar -C "${pkgdir}" -xf data.tar.gz
- install -d "$pkgdir/usr/share/licenses/$pkgname/"
- mv "$pkgdir/usr/lib/$_name/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/"
- chown -R root:root "$pkgdir/"
+ tar -C "$pkgdir" -xf data.tar.gz
+ install -Dm644 "$pkgdir/usr/lib/emulsion/LICENSE.txt" -t "$pkgdir/usr/share/licenses/emulsion"
+# Fix error
+ ln -s /usr/lib/libdav1d.so "$pkgdir/usr/lib/libdav1d.so.6"
}