summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkhai96_2020-08-11 09:16:41 +0700
committerkhai96_2020-08-11 09:16:41 +0700
commit65befe7a4fe8ca272453557cf700d72d653b36b1 (patch)
tree8f991559038e94c33a3025edc469cd034e535527
downloadaur-65befe7a4fe8ca272453557cf700d72d653b36b1.tar.gz
Clean
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD40
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4c40bd83483
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gnabel
+ pkgdesc = A translation app for GTK environments based on Google Translate
+ pkgver = 0.0.0
+ pkgrel = 2
+ url = https://github.com/gi-lom/gnabel
+ arch = any
+ license = GPL-3.0
+ depends = python>=3
+ depends = python-pyperclip
+ depends = python-gobject
+ depends = python-googletrans
+ depends = python-gtts
+ depends = python-pydub
+ source = https://github.com/gi-lom/gnabel/archive/57ff9c3d3631b04ddb8369e31ad2cfe46ec9099f.zip
+ sha512sums = SKIP
+
+pkgname = gnabel
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4095477fbdc1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.git*
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..951ee01bc0d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Hoàng Văn Khải <hvksmr1996@gmail.com>
+
+set -o errexit -o pipefail
+
+pkgname='gnabel'
+pkgver='0.0.0'
+pkgrel='2'
+pkgdesc='A translation app for GTK environments based on Google Translate'
+arch=('any')
+depends=(
+ 'python>=3'
+ 'python-pyperclip'
+ 'python-gobject'
+ 'python-googletrans' # aur only
+ 'python-gtts' # aur only
+ 'python-pydub' # aur only
+)
+url='https://github.com/gi-lom/gnabel'
+license=('GPL-3.0')
+_git_ref='57ff9c3d3631b04ddb8369e31ad2cfe46ec9099f'
+source=(
+ "https://github.com/gi-lom/gnabel/archive/$_git_ref.zip"
+)
+sha512sums=('SKIP')
+
+package() {
+ cd "gnabel-$_git_ref"
+
+ msg2 'Installing LICENSE'
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ msg2 'Installing executable'
+ install -Dm755 gnabel.py "$pkgdir/usr/bin/gnabel"
+
+ msg2 'Installing desktop file'
+ install -Dm755 gnabel.desktop "$pkgdir/usr/share/applications/gnabel.desktop"
+
+ msg2 'Installing icon'
+ install -Dm644 icon.png "$pkgdir/usr/share/icons/hicolor/64x64/apps/gnabel.png"
+}