summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2021-08-15 19:50:50 +0300
committerIgor Dyatlov2021-08-15 19:50:50 +0300
commitec0d5cffd2d8575becf905e3de4bc3cea0c98c4e (patch)
tree8ef0209db3d2add048e8cfbd725ddb44c9da45c7
downloadaur-ec0d5cffd2d8575becf905e3de4bc3cea0c98c4e.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD37
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d38321cbd03
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = emulsion-palette-git
+ pkgdesc = Store your palettes in an easy way, and edit them if needed
+ pkgver = r85.550623a
+ pkgrel = 1
+ url = https://github.com/lainsce/emulsion
+ arch = any
+ license = GPL3
+ checkdepends = appstream-glib
+ makedepends = meson
+ makedepends = gobject-introspection
+ makedepends = vala
+ depends = glib2
+ depends = gtk4
+ depends = libadwaita
+ depends = json-glib
+ depends = libgee
+ provides = emulsion-palette
+ conflicts = emulsion-palette
+ source = git+https://github.com/lainsce/emulsion.git
+ sha256sums = SKIP
+
+pkgname = emulsion-palette-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd5cb965ba43
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+
+pkgname=emulsion-palette-git
+pkgver=r85.550623a
+pkgrel=1
+pkgdesc="Store your palettes in an easy way, and edit them if needed"
+arch=('any')
+url="https://github.com/lainsce/emulsion"
+license=('GPL3')
+depends=('glib2' 'gtk4' 'libadwaita' 'json-glib' 'libgee')
+makedepends=('meson' 'gobject-introspection' 'vala')
+checkdepends=('appstream-glib')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(git+$url.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-palette-git}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ arch-meson ${pkgname%-palette-git} build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja install -C build
+}