summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfuzzbop2020-05-02 08:53:21 -0400
committerfuzzbop2020-05-02 08:53:21 -0400
commite6e8823a417793a0bbe1a751aac4a6a34683d8f8 (patch)
tree3f5c7de8bc504642b2b106e1e4d5727ad791c4bc
downloadaur-e6e8823a417793a0bbe1a751aac4a6a34683d8f8.tar.gz
-First Commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD25
-rw-r--r--emuMenu.sh3
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..688669f66d9c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = emumenu-git
+ pkgdesc = emuMenu is a simple rom launcher made with very large collections and no flair in mind.
+ pkgver = r59.834a62a
+ pkgrel = 1
+ url = https://github.com/fuzzbop/emuMenu
+ arch = i686
+ arch = x86_64
+ license = QPL
+ license = GPL2
+ license = GPLv3
+ makedepends = git
+ depends = python
+ depends = python-pyqt5
+ source = git+https://github.com/fuzzbop/emuMenu.git
+ source = emuMenu.sh
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = emumenu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c910bafd40fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+#Maintainer: Fuzzbop <fuzzbop@gmail.com>
+pkgname=emumenu-git
+pkgver=r59.834a62a
+pkgrel=1
+pkgdesc="emuMenu is a simple rom launcher made with very large collections and no flair in mind."
+arch=('i686' 'x86_64')
+url="https://github.com/fuzzbop/emuMenu"
+license=('QPL' 'GPL2' 'GPLv3')
+depends=('python' 'python-pyqt5')
+makedepends=('git')
+source=("git+$url.git" "emuMenu.sh")
+md5sums=('SKIP' 'SKIP')
+_pkgname=emuMenu
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_pkgname"
+ mkdir -p $pkgdir/usr/lib/$_pkgname
+ cp -r * $pkgdir/usr/lib/$_pkgname/
+ install -Dm755 $srcdir/$_pkgname.sh $pkgdir/usr/bin/$_pkgname
+}
diff --git a/emuMenu.sh b/emuMenu.sh
new file mode 100644
index 000000000000..01bab2376855
--- /dev/null
+++ b/emuMenu.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /usr/lib/emuMenu
+python3 emuMenu.py