summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmile Pesik2015-07-08 14:12:01 +0100
committerEmile Pesik2015-07-08 14:12:01 +0100
commit73f3e068b1528aae3de6b75fc7aacbddf33ad181 (patch)
treedabaaa106b5a916a559f96c5c7a23a7025fc5c26
downloadaur-73f3e068b1528aae3de6b75fc7aacbddf33ad181.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
-rw-r--r--emusicremote.desktop11
-rw-r--r--emusicremote.install15
4 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bec59f7d8aaa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emusicremote
+ pkgdesc = Self contained browser + download client for eMusic based on Mozilla's XULRunner.
+ pkgver = 1.0.0.3_beta1
+ pkgrel = 2
+ url = http://emusic.mozdev.org/remote.html
+ install = emusicremote.install
+ arch = i686
+ arch = x86_64
+ license = Included
+ source = emusicremote.desktop
+ source = http://downloads.mozdev.org/emusic/remote/emusic_remote_linux_current.tar.gz
+ md5sums = 55d7e13ac63c0788ab6e00edb2e4579d
+ md5sums = 37f7fb46ab65367d3d062dd214a8f5b1
+
+pkgname = emusicremote
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2cf196cf2f8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: Emile Pesik <this.id.was.still.free at gmail dot com>
+
+pkgname=emusicremote
+pkgver=1.0.0.3_beta1
+pkgrel=2
+pkgdesc="Self contained browser + download client for eMusic based on Mozilla's XULRunner."
+url="http://emusic.mozdev.org/remote.html"
+conflicts=()
+provides=()
+depends=()
+arch=('i686' 'x86_64')
+license=('Included')
+install=emusicremote.install
+source=('emusicremote.desktop' \
+"http://downloads.mozdev.org/emusic/remote/emusic_remote_linux_current.tar.gz")
+md5sums=('55d7e13ac63c0788ab6e00edb2e4579d'
+ '37f7fb46ab65367d3d062dd214a8f5b1')
+
+build() {
+ # install application
+ mkdir -p $startdir/pkg/usr/share
+ cp -Rd $startdir/src/builds/emusicremote $startdir/pkg/usr/share/emusicremote
+
+ # install desktop files
+ install -D -m 644 $startdir/pkg/usr/share/emusicremote/xulrunner48.png \
+ $startdir/pkg/usr/share/pixmaps/emusicremote.png
+ install -D -m 644 $startdir/emusicremote.desktop \
+ $startdir/pkg/usr/share/applications/emusicremote.desktop
+
+ # install license files
+ install -Dm644 "$srcdir/builds/$pkgname/license.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/license.txt" || return 1
+}
diff --git a/emusicremote.desktop b/emusicremote.desktop
new file mode 100644
index 000000000000..29d4c9dfbc52
--- /dev/null
+++ b/emusicremote.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Name=eMusic Remote
+GenericName=eMusic browser + download client
+Comment=eMusic browser + download client for Linux, based on XULRunner.
+Exec=emusicremote
+Icon=emusicremote
+Terminal=false
+Type=Application
+Categories=GNOME;GTK;AudioVideo;
diff --git a/emusicremote.install b/emusicremote.install
new file mode 100644
index 000000000000..79fbc209877b
--- /dev/null
+++ b/emusicremote.install
@@ -0,0 +1,15 @@
+post_install() {
+ if [ ! -e /usr/bin/emusicremote ]; then
+ ln -s /usr/share/emusicremote/emusicremote /usr/bin/emusicremote
+ fi
+ echo ">>>"
+ echo ">>> By installing and running this you"
+ echo ">>> agree to any included license,"
+ echo ">>> either from eMusic or otherwise."
+ echo ">>>"
+}
+
+op=$1
+shift
+
+$op $*