summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRuben De Smet2017-06-02 18:48:08 +0200
committerRuben De Smet2017-06-02 18:48:08 +0200
commit32aa80225fbac39058df5e2c2bfe3db701d84b89 (patch)
tree9c0c2010eee6c501d7aa52b6578e4bc5dcf76f2a
downloadaur-32aa80225fbac39058df5e2c2bfe3db701d84b89.tar.gz
1.5
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c0cb4937b8f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Fri Jun 2 16:47:54 UTC 2017
+pkgbase = emv-cap
+ pkgdesc = EMV CAP implementation in python
+ pkgver = 1.5
+ pkgrel = 1
+ url = https://sites.uclouvain.be/EMV-CAP/Application/
+ arch = any
+ license = CC-BY-ND-2.0
+ depends = python2
+ depends = python2-crypto
+ depends = python2-pyscard
+ source = https://sites.uclouvain.be/EMV-CAP/resources/Data/EMVCAP-1.5.tar.gz
+ sha512sums = 7ab6752b0f883a0f22ab301231586cbf30485adfe36bcb62a733e25bd69f0443f15dff63b038460f71a14ce02adc71a410ba7689530eabb9441af6906cf18469
+
+pkgname = emv-cap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6251aaa859ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Ruben De Smet <me at rubdos dot be>
+
+pkgname='emv-cap'
+pkgver="1.5"
+pkgrel=1
+pkgdesc='EMV CAP implementation in python'
+url='https://sites.uclouvain.be/EMV-CAP/Application/'
+license=('CC-BY-ND-2.0')
+
+source=(
+ 'https://sites.uclouvain.be/EMV-CAP/resources/Data/EMVCAP-1.5.tar.gz'
+)
+sha512sums=(
+ '7ab6752b0f883a0f22ab301231586cbf30485adfe36bcb62a733e25bd69f0443f15dff63b038460f71a14ce02adc71a410ba7689530eabb9441af6906cf18469'
+)
+arch=('any')
+depends=(
+ 'python2'
+ 'python2-crypto'
+ 'python2-pyscard'
+)
+
+build() {
+ cd "$srcdir"/EMVCAP-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir"/EMVCAP-$pkgver
+ python2 setup.py install --root="$pkgdir"/ --optimize=1
+ sed -i -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
+ $(find "${pkgdir}" -name '*.py')
+}