summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBehnam Momeni2015-06-13 16:38:21 +0430
committerBehnam Momeni2015-06-13 16:38:21 +0430
commita5a0bb5ee6f393224960a90a4e7d8225022eca8d (patch)
tree8c9ccbe36d77691f7cce452fce5f4c2f1edc19e0
downloadaur-a5a0bb5ee6f393224960a90a4e7d8225022eca8d.tar.gz
Migrating enchant-hspell package to AUR4
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD38
-rw-r--r--warnings-fix.patch33
4 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..391ad9548538
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = enchant-hspell
+ pkgdesc = An enchant provider plugin which adds support for Hspell backend
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = http://www.abisource.com/enchant/
+ arch = any
+ license = LGPL
+ depends = enchant-pure
+ depends = hspell
+ options = !libtool
+ source = http://www.abisource.com/downloads/enchant/1.6.0/enchant-1.6.0.tar.gz
+ source = warnings-fix.patch
+ sha1sums = 321f9cf0abfa1937401676ce60976d8779c39536
+ sha1sums = 8e23f2b350e77c2a2e9accf1ce1b9a18aefb69ff
+
+pkgname = enchant-hspell
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f72d5fb6ac3d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+enchant-*.tar.gz
+*.pkg.tar.xz
+*~
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c7c56b47859
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Behnam Momeni <sbmomeni [at the] gmail [dot] com>
+
+pkgname=('enchant-hspell')
+
+_pkgname=enchant
+pkgver=1.6.0
+pkgrel=1
+
+pkgdesc="An enchant provider plugin which adds support for Hspell backend"
+url="http://www.abisource.com/enchant/"
+
+arch=('any')
+license=('LGPL')
+
+depends=("enchant-pure" "hspell")
+options=('!libtool')
+
+source=("http://www.abisource.com/downloads/${_pkgname}/${pkgver}/${_pkgname}-${pkgver}.tar.gz"
+ "warnings-fix.patch")
+sha1sums=('321f9cf0abfa1937401676ce60976d8779c39536'
+ '8e23f2b350e77c2a2e9accf1ce1b9a18aefb69ff')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ patch -p1 -i ../warnings-fix.patch
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ ./configure --prefix=/usr --disable-static --disable-ispell --disable-myspell --disable-aspell --disable-voikko --disable-uspell --disable-zemberek --enable-hspell
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ install -D -s -m 755 src/hspell/.libs/libenchant_hspell.so "${pkgdir}/usr/lib/enchant/libenchant_hspell.so"
+}
+
diff --git a/warnings-fix.patch b/warnings-fix.patch
new file mode 100644
index 000000000000..d97935a6c429
--- /dev/null
+++ b/warnings-fix.patch
@@ -0,0 +1,33 @@
+diff -aur enchant-1.6.0/src/enchant.c enchant-1.6.0.new/src/enchant.c
+--- enchant-1.6.0/src/enchant.c 2010-04-02 01:23:37.000000000 +0430
++++ enchant-1.6.0.new/src/enchant.c 2013-07-31 23:26:05.244144048 +0430
+@@ -208,7 +208,9 @@
+ GSList *module_dirs = NULL;
+
+ char * module_dir = NULL;
++#ifndef ENCHANT_GLOBAL_MODULE_DIR
+ char * prefix = NULL;
++#endif
+
+ {
+ char* user_module_dir;
+@@ -840,6 +842,7 @@
+ size_t i, j;
+
+ session = ((EnchantDictPrivateData*)dict->enchant_private_data)->session;
++ (void) session; // unused
+
+ for(i = 0; i < n_new_suggs; i++)
+ {
+diff -aur enchant-1.6.0/src/pwl.c enchant-1.6.0.new/src/pwl.c
+--- enchant-1.6.0/src/pwl.c 2010-04-02 01:23:37.000000000 +0430
++++ enchant-1.6.0.new/src/pwl.c 2013-07-31 23:27:14.200816371 +0430
+@@ -282,7 +282,7 @@
+ {
+ char buffer[BUFSIZ];
+ char* line;
+- size_t line_number = 1;
++ unsigned int line_number = 1;
+ FILE *f;
+ struct stat stats;
+