summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPrabuddhMathur2023-01-08 01:28:51 +0000
committerPrabuddhMathur2023-01-08 01:28:51 +0000
commitc5ad52418541595f3c4e542030cba67ea55a47e0 (patch)
treef452594c088bc0637ffb74774f365abe273ed8eb
downloadaur-c5ad52418541595f3c4e542030cba67ea55a47e0.tar.gz
Initial Push
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD44
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bcc324335cb0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = enchiridion-robin-homer-git
+ pkgdesc = A script to run The Enchiridion of Epictetus narrated by Robin Homer of Vox Stoica on Youtube. Specific parts can be played along with any random part from it.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/PrabuddhMathur/the_enchiridion.git
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = git
+ depends = ffmpeg
+ provides = the_enchiridion
+ source = git+https://github.com/PrabuddhMathur/the_enchiridion.git
+ md5sums = SKIP
+
+pkgname = enchiridion-robin-homer-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e6c6aa79531
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Prabuddh Mathur <prabuddhmathur2002@gmail.com>
+pkgname=enchiridion-robin-homer-git
+pkgver=1.0.r1.e6b14ab
+pkgrel=1
+epoch=
+pkgdesc="A script to run The Enchiridion of Epictetus narrated by Robin Homer of Vox Stoica on Youtube. Specific parts can be played along with any random part from it."
+arch=(x86_64 i686)
+url="https://github.com/PrabuddhMathur/enchiridion-robin-homer-git.git"
+license=('MIT')
+groups=()
+depends=(ffmpeg)
+makedepends=(git)
+checkdepends=()
+optdepends=()
+provides=(the_enchiridion)
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+$url")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver(){
+ cd "${_pkgname}"
+ printf "1.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+package() {
+ cd $pkgname
+ ls
+ sudo mkdir -p "/usr/bin/${pkgname}"
+ cp -rf * "/usr/bin/${pkgname}"
+ mv "/usr/bin/${pkgname}/enchiridion.sh" /usr/bin/
+ rm -rf $pkgname
+
+}