summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvgeny Pokhilko2018-08-13 23:16:00 +1000
committerEvgeny Pokhilko2018-08-13 23:16:00 +1000
commitd4c40333a28fc3fd49d8856ddafbb04b54f91040 (patch)
tree9b41c9ca57a59ef649471221ced48f389b5093e6
parent8b1a667242f0b872b4a1aec6940c161aac39f39d (diff)
downloadaur-d4c40333a28fc3fd49d8856ddafbb04b54f91040.tar.gz
add botan as another dependency. see if it works
-rwxr-xr-x.SRCINFO2
-rwxr-xr-xPKGBUILD4
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cedc86fba842..d941822f5cce 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,6 +9,8 @@ pkgbase = encryptpad
makedepends = git
depends = qt5-base
depends = hicolor-icon-theme
+ depends = python
+ depends = botan
options = !makeflags
source = https://github.com/evpo/EncryptPad/releases/download/v0.4.0.2/encryptpad0_4_0_2_src.tar.gz
source = https://github.com/evpo/EncryptPad/releases/download/v0.4.0.2/encryptpad0_4_0_2_src.tar.gz.asc
diff --git a/PKGBUILD b/PKGBUILD
index f5c234c84669..033f42c4e41f 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="Minimalist secure text editor and file encryptor that implements RFC 48
arch=(i686 x86_64)
url="https://github.com/evpo/${_pkgname}"
license=('GPL2')
-depends=('qt5-base' 'hicolor-icon-theme' 'python')
+depends=('qt5-base' 'hicolor-icon-theme' 'python' 'botan')
makedepends=('git')
options=('!makeflags')
validpgpkeys=('634BFC0CCC426C74389D89310F1CFF71A2813E85')
@@ -18,7 +18,7 @@ sha1sums=('SKIP' 'SKIP')
build() {
cd "$srcdir/encryptpad$(echo -n $pkgver | sed -r 's/\./_/g')_src"
- ./configure.sh --all
+ ./configure.sh --all --use-system-libs
}
package() {