summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrede Hundewadt2020-09-07 08:49:00 +0200
committerFrede Hundewadt2020-09-07 08:49:00 +0200
commitf01515912c6cd5a1f5401745f6d229321cb68032 (patch)
tree77de03fd3d54b958175a71349f14181d40ec19ba
downloadaur-f01515912c6cd5a1f5401745f6d229321cb68032.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
-rw-r--r--theme.install22
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73f48ac0f9e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = endeavouros-galleon
+ pkgver = 0.4
+ pkgrel = 1
+ install = theme.install
+ arch = any
+ license = MIT
+ depends = grub
+ provides = galleon-grub-theme
+ replaces = endeavouros-nix
+ source = https://github.com/fhdk/endeavouros-galleon/archive/v0.4.tar.gz
+ md5sums = 4d178d06a8e7a17db4ba1855967307e1
+
+pkgname = endeavouros-galleon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..793682ea79d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: fhdk <arch at nix dk>
+
+pkgname='endeavouros-galleon'
+pgkdesc='EndeavourOS Galleon GRUB Theme'
+pkgver=0.4
+pkgrel=1
+arch=('any')
+license=('MIT')
+source=("https://github.com/fhdk/endeavouros-galleon/archive/v$pkgver.tar.gz")
+depends=('grub')
+install=theme.install
+provides=('galleon-grub-theme')
+replaces=('endeavouros-nix')
+sha256sum=('')
+
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ install -d -m755 $pkgdir/usr/share/grub/themes/$pkgname
+ cp -R $pkgname $pkgdir/usr/share/grub/themes/
+}
+md5sums=('4d178d06a8e7a17db4ba1855967307e1')
diff --git a/theme.install b/theme.install
new file mode 100644
index 000000000000..87cdcebdbef8
--- /dev/null
+++ b/theme.install
@@ -0,0 +1,22 @@
+# defaults file
+grub_default="/etc/default/grub"
+
+post_install() {
+ # replace the line GRUB_THEME with our theme
+ sed -i '/\GRUB_THEME\=/c\GRUB_THEME="/usr/share/grub/themes/endeavouros-galleon/theme.txt"' ${grub_default}
+
+ # comment the GRUB_BACKGROUND= line in /etc/default/grub
+ sed /GRUB_BACKGROUND\=/s/^/#/ ${grub_default} > /dev/null
+
+ # rebuild grub config
+ grub-mkconfig -o /boot/grub/grub.cfg
+}
+
+post_remove() {
+
+ # comment the GRUB_THEME= line in /etc/default/grub
+ sed /GRUB_THEME\=/s/^/#/ ${grub_default} > /dev/null
+
+ # rebuild grub config
+ grub-mkconfig -o /boot/grub/grub.cfg
+}