summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael M2022-10-28 15:32:36 +0200
committerMichael M2022-10-28 15:32:36 +0200
commit977c0c410377bfc5e59c63f779ddaa5c2848f0e3 (patch)
treede8e7b30b5f4321bcd994ba4dc5f434742fc32e3
parentabf0a68bad7a7cbc11ed53395c0956baca798219 (diff)
downloadaur-977c0c410377bfc5e59c63f779ddaa5c2848f0e3.tar.gz
Cleanup and minor tweaks for the script
-rw-r--r--PKGBUILD2
-rw-r--r--opera.patch36
2 files changed, 28 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f6f7985dd63c..716c980cb806 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgbase=endpoint-verification
pkgname=("endpoint-verification" "endpoint-verification-chrome")
_pkgver="2022.06.14.c454816986-00"
pkgver="$(tr '-' '_' <<< $_pkgver)"
-pkgrel=6
+pkgrel=7
pkgdesc="Endpoint Verification Helper"
arch=(x86_64)
url="https://chrome.google.com/webstore/detail/endpoint-verification/callobklhcbilhphinckomhgkigmfocg"
diff --git a/opera.patch b/opera.patch
index 70739baa89af..e7d1f3e33050 100644
--- a/opera.patch
+++ b/opera.patch
@@ -1,15 +1,24 @@
-diff --unified --recursive --text opt.orig/google/endpoint-verification/bin/device_state.sh opt.new/google/endpoint-verification/bin/device_state.sh
---- opt/google/endpoint-verification/bin/device_state.sh 2000-01-01 01:00:00.000000000 +0100
-+++ opt/google/endpoint-verification/bin/device_state.sh 2022-08-12 12:25:07.140577678 +0200
-@@ -12,6 +12,7 @@
+diff '--color=auto' --unified --recursive --text --color opt.old/google/endpoint-verification/bin/device_state.sh opt.new/google/endpoint-verification/bin/device_state.sh
+--- opt/google/endpoint-verification/bin/device_state.sh 2000-01-01 00:00:00.000000000 +0100
++++ opt/google/endpoint-verification/bin/device_state.sh 2022-10-28 14:48:07.830135262 +0200
+@@ -6,15 +6,12 @@
+ CAT=/bin/cat
+ CUT=/usr/bin/cut
+ DCONF=/usr/bin/dconf
+-ECHO=/bin/echo
+ GREP=/bin/grep
+ GSETTINGS=/usr/bin/gsettings
LSBLK=/bin/lsblk
- MOUNTPOINT=/bin/mountpoint
+-MOUNTPOINT=/bin/mountpoint
PRINTF=/usr/bin/printf
+-STAT=/usr/bin/stat
+REV=/usr/bin/rev
- STAT=/usr/bin/stat
TR=/usr/bin/tr
- UDEVADM=/bin/udevadm
-@@ -32,40 +33,26 @@
+-UDEVADM=/bin/udevadm
+
+ INSTALL_PREFIX=/opt/google/endpoint-verification
+ GENERATED_ATTRS_FILE="$INSTALL_PREFIX/var/lib/device_attrs"
+@@ -32,40 +29,26 @@
fi
}
@@ -68,7 +77,7 @@ diff --unified --recursive --text opt.orig/google/endpoint-verification/bin/devi
esac
}
-@@ -77,7 +64,11 @@
+@@ -77,7 +60,11 @@
*ubuntu*|*debian*)
OS_VERSION=$("$GREP" -i '^VERSION_ID=' "$OS_INFO_FILE" | "$AWK" -F= '{ print $2 }' | "$TR" -d '"')
;;
@@ -80,3 +89,12 @@ diff --unified --recursive --text opt.orig/google/endpoint-verification/bin/devi
;;
esac
else
+@@ -118,7 +105,7 @@
+ }
+
+ get_hostname() {
+- HOSTNAME="$(/bin/hostname)"
++ HOSTNAME="$(hostname)"
+ }
+
+ get_model() {