summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSalama2022-09-26 13:57:45 +0300
committerSalama2022-09-26 13:57:45 +0300
commit925f0941a923fe3b55cdc6b3d82bee6c3f3f065e (patch)
tree9f6c32fcddbc62fb738929f414c58c97c31cbec2
downloadaur-925f0941a923fe3b55cdc6b3d82bee6c3f3f065e.tar.gz
Publish package
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db6cce4cdf05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = energygraph
+ pkgdesc = Graphs the energy use of a host inside a text terminal, using intel-rapl data from the /sys filesystem. Uses RAPL interface in /sys to determine the energy use of different zones, and graphs it in a text terminal.
+ pkgver = 1.0_1
+ pkgrel = 1
+ url = https://github.com/stolk/energygraph
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = make
+ source = git+https://github.com/stolk/energygraph.git#tag=395e38c63410f8edf6882826206d9d7247c92c5c
+ sha256sums = SKIP
+
+pkgname = energygraph
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a28ebe60bfe0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Salama <salama@salama.xyz>
+pkgname=energygraph
+pkgver=1.0_1
+pkgrel=1
+pkgdesc="Graphs the energy use of a host inside a text terminal, using intel-rapl data from the /sys filesystem. Uses RAPL interface in /sys to determine the energy use of different zones, and graphs it in a text terminal."
+arch=('x86_64')
+url="https://github.com/stolk/$pkgname"
+license=('MIT')
+makedepends=('git' 'make')
+_tag=395e38c63410f8edf6882826206d9d7247c92c5c
+source=(git+https://github.com/stolk/$pkgname.git#tag=$_tag)
+sha256sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+
+ make DESTDIR="$pkgdir/" install
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}