summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12023-04-08 03:36:34 +0800
committerChocobo12023-04-08 03:36:34 +0800
commita7047ce681734d73946b4af792ff21f1d25534d9 (patch)
treeb375055cc0c273503c0901bd7341b0395cad9065
parentb42b08ddbf73f657a83b0b404486a51a17104e25 (diff)
downloadaur-enet-git.tar.gz
upgpkg: enet-git 1.3.17.r29.gea4607a-1
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8353ac38be5..9f31d0936922 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = enet-git
pkgdesc = A thin, simple and robust network communication layer on top of UDP
- pkgver = r254.g0eaf48e
+ pkgver = 1.3.17.r29.gea4607a
pkgrel = 1
url = http://enet.bespin.org/
arch = i686
@@ -8,11 +8,10 @@ pkgbase = enet-git
license = MIT
makedepends = git
depends = glibc
- provides = enet
+ provides = enet=1.3.17.r29.gea4607a
conflicts = enet
options = staticlibs
source = git+https://github.com/lsalzman/enet.git
sha256sums = SKIP
pkgname = enet-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 0316b249c5e1..530a7e57ce15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=enet-git
-pkgver=r254.g0eaf48e
+pkgver=1.3.17.r29.gea4607a
pkgrel=1
pkgdesc="A thin, simple and robust network communication layer on top of UDP"
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ url="http://enet.bespin.org/"
license=('MIT')
depends=('glibc')
makedepends=('git')
-provides=('enet')
+provides=("enet=$pkgver")
conflicts=('enet')
options=('staticlibs')
source=("git+https://github.com/lsalzman/enet.git")
@@ -19,9 +19,10 @@ sha256sums=('SKIP')
pkgver() {
cd "enet"
- _rev=$(git rev-list --count --all)
+ _tag=$(git tag -l --sort -v:refname | grep -E '^v?[0-9\.]+$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
_hash=$(git rev-parse --short HEAD)
- printf "r%s.g%s" "$_rev" "$_hash"
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//'
}
build() {