summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12019-05-14 20:39:00 +0800
committerChocobo12019-05-14 20:39:37 +0800
commitb42b08ddbf73f657a83b0b404486a51a17104e25 (patch)
tree27fd10b881ed37e97dd99fb446395b222320754b
downloadaur-b42b08ddbf73f657a83b0b404486a51a17104e25.tar.gz
newpkg: enet-git r254.g0eaf48e-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8353ac38be5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = enet-git
+ pkgdesc = A thin, simple and robust network communication layer on top of UDP
+ pkgver = r254.g0eaf48e
+ pkgrel = 1
+ url = http://enet.bespin.org/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = glibc
+ provides = enet
+ conflicts = enet
+ options = staticlibs
+ source = git+https://github.com/lsalzman/enet.git
+ sha256sums = SKIP
+
+pkgname = enet-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0316b249c5e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=enet-git
+pkgver=r254.g0eaf48e
+pkgrel=1
+pkgdesc="A thin, simple and robust network communication layer on top of UDP"
+arch=('i686' 'x86_64')
+url="http://enet.bespin.org/"
+license=('MIT')
+depends=('glibc')
+makedepends=('git')
+provides=('enet')
+conflicts=('enet')
+options=('staticlibs')
+source=("git+https://github.com/lsalzman/enet.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "enet"
+
+ _rev=$(git rev-list --count --all)
+ _hash=$(git rev-parse --short HEAD)
+ printf "r%s.g%s" "$_rev" "$_hash"
+}
+
+build() {
+ cd "enet"
+
+ autoreconf -fi
+ ./configure \
+ --prefix="/usr"
+ make
+}
+
+package() {
+ cd "enet"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/enet"
+}