summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgandalf32015-06-22 17:47:12 -0700
committergandalf32015-06-22 17:47:12 -0700
commit1726b127d0ae85268a823a6f13001290b711854b (patch)
tree804353de3d3bb13c10aceb56fdc7e78fa8ce003a
downloadaur-1726b127d0ae85268a823a6f13001290b711854b.tar.gz
initial import
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD60
-rwxr-xr-xenigma-dev-git.install14
-rw-r--r--lateralgm5
-rw-r--r--lateralgm.desktop11
5 files changed, 125 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ff3917518b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = enigma-dev-git
+ pkgdesc = ENIGMA, the Extensible Non-Interpreted Game Maker Augmentation.
+ pkgver = 0.0.0
+ pkgrel = 3
+ url = http://enigma-dev.org
+ install = enigma-dev-git.install
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = git
+ makedepends = python
+ depends = alure
+ depends = zlib
+ depends = openal
+ depends = libx11
+ depends = libgl
+ depends = mesa
+ depends = gtk2
+ depends = dumb
+ depends = java-runtime
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ provides = lateralgm
+ conflicts = lateralgm
+ source = lateralgm
+ source = lateralgm.desktop
+ source = git://github.com/enigma-dev/enigma-dev.git
+ source = http://enigma-dev.org/docs/wiki/images/4/47/Lateralgmlogo.png
+ md5sums = b6eea00e8293de6307bc96a78956159f
+ md5sums = 0eca65efd1ad5b863e22a284be894b59
+ md5sums = SKIP
+ md5sums = e6daacba04f0491b256f8a4d2cc9181a
+
+pkgname = enigma-dev-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d97610b77405
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: gandalf3 <zzyxpaw at gmail dot com>
+
+pkgname=('enigma-dev-git')
+pkgver=0.0.0
+pkgrel=3
+pkgdesc="ENIGMA, the Extensible Non-Interpreted Game Maker Augmentation."
+url="http://enigma-dev.org"
+arch=('x86_64' 'i686')
+license=('GPL')
+depends=('alure' 'zlib' 'openal' 'libx11' 'libgl' 'mesa' 'gtk2' 'dumb' 'java-runtime' 'desktop-file-utils' \
+ 'hicolor-icon-theme')
+
+makedepends=('git' 'python')
+conflicts=('lateralgm')
+provides=('lateralgm')
+install='enigma-dev-git.install'
+source=('lateralgm' 'lateralgm.desktop' 'git://github.com/enigma-dev/enigma-dev.git' 'http://enigma-dev.org/docs/wiki/images/4/47/Lateralgmlogo.png')
+md5sums=('b6eea00e8293de6307bc96a78956159f' '0eca65efd1ad5b863e22a284be894b59' 'SKIP' 'e6daacba04f0491b256f8a4d2cc9181a')
+
+build() {
+ cd "${srcdir}/enigma-dev"
+ msg "Starting python config.."
+ python install.py
+
+ cd "${srcdir}/enigma-dev"
+ msg "Starting compile.."
+ make
+ }
+
+pkgver () {
+ cd "${srcdir}/enigma-dev"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ }
+
+package() {
+ mkdir "${pkgdir}/opt/"
+
+# Change .desktop settings
+ sed -i 's/enigma/enigma-dev-git/' "${srcdir}/enigma-dev/packages/linux/usr/bin/enigma-dev"
+ sed -i 's/Terminal=true/Terminal=false/' "${srcdir}/enigma-dev/packages/linux/usr/share/applications/enigma-dev.desktop"
+ echo 'Comment=ENIGMA, the Extensible Non-Interpreted Game Maker Augmentation.' >> "${srcdir}/enigma-dev/packages/linux/usr/share/applications/enigma-dev.desktop"
+
+ mkdir -p "${pkgdir}/usr/share"
+ mkdir "${pkgdir}/usr/bin"
+ cp -r -a "${srcdir}/enigma-dev/packages/linux/usr/share" "${pkgdir}/usr/"
+ cp -r -a "${srcdir}/enigma-dev/packages/linux/usr/bin" "${pkgdir}/usr/"
+ cp -r -a "${srcdir}/enigma-dev" "${pkgdir}/opt/${pkgname}"
+ chmod -R 755 "${pkgdir}/opt/${pkgname}"
+
+ cd "${pkgdir}/usr/bin/"
+ install -D "${srcdir}/lateralgm" "${pkgdir}/usr/bin/lateralgm"
+ chmod +x "${pkgdir}/usr/bin/lateralgm"
+ chmod +x "${pkgdir}/usr/bin/enigma-dev"
+ install -D "${srcdir}/lateralgm.desktop" "${pkgdir}/usr/share/applications/lateralgm.desktop"
+ install -D "${srcdir}/Lateralgmlogo.png" "${pkgdir}/usr/share/icons/hicolor/128x128/apps/lateralgm.png"
+ install -D "${pkgdir}/usr/share/pixmaps/enigma-dev.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/enigma-dev.svg"
+
+# remove some extra stuff to help reduce package size; more of this is may be possible.
+ rm -rf "${pkgdir}/usr/share/${pkgname}/packages"
+} \ No newline at end of file
diff --git a/enigma-dev-git.install b/enigma-dev-git.install
new file mode 100755
index 000000000000..988026f078df
--- /dev/null
+++ b/enigma-dev-git.install
@@ -0,0 +1,14 @@
+# Install
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_remove() {
+ post_upgrade
+} \ No newline at end of file
diff --git a/lateralgm b/lateralgm
new file mode 100644
index 000000000000..7c47a0eab86f
--- /dev/null
+++ b/lateralgm
@@ -0,0 +1,5 @@
+#!/bin/bash
+
+# excute lateralgm jar file.
+cd /opt/enigma-dev-git/ # fix for strange bug, where you have to be in the same directory as the .jar.
+java -jar lateralgm.jar \ No newline at end of file
diff --git a/lateralgm.desktop b/lateralgm.desktop
new file mode 100644
index 000000000000..2133901a197c
--- /dev/null
+++ b/lateralgm.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Name=LateralGM
+Exec=lateralgm
+Comment=Game Development IDE for Enigma written in java
+Icon=lateralgm
+Terminal=false
+Path=/usr/bin/
+Categories=Application;Development;IDE;
+StartupNotify=true
+MimeType=application;application/x-gm81;application/x-gmk;application/x-gm6;application/x-gmd;application/x-egm;application/x-gm50;application/x-gm51;application/x-gm52;application/x-gm53;application/x-gm60;application/x-gm61;application/x-gm71;application/x-gm80;application/x-gm81; \ No newline at end of file