summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2016-01-05 18:23:54 +0100
committeranthraxx2016-01-05 18:23:54 +0100
commitb9a65087b1b93f42ef4f0a7b79b39a6190ace731 (patch)
tree14818fc4dd6f788da5b93b7ad57eba84c3a56a05
downloadaur-b9a65087b1b93f42ef4f0a7b79b39a6190ace731.tar.gz
addpkg: enjarify-git 1.0.0.29.bf9033b-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD50
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fcb14353b683
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Jan 5 17:23:54 UTC 2016
+pkgbase = enjarify-git
+ pkgdesc = Translates Dalvik bytecode to equivalent Java bytecode
+ pkgver = 1.0.0.29.bf9033b
+ pkgrel = 1
+ url = https://github.com/google/enjarify
+ arch = any
+ license = Apache
+ checkdepends = java-runtime
+ makedepends = git
+ depends = python
+ provides = enjarify
+ conflicts = enjarify
+ source = enjarify-git::git+https://github.com/google/enjarify
+ sha512sums = SKIP
+
+pkgname = enjarify-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89c34a585c30
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Lance Chen <cyen0312@gmail.com>
+
+pkgname=enjarify-git
+pkgver=1.0.0.29.bf9033b
+pkgrel=1
+pkgdesc="Translates Dalvik bytecode to equivalent Java bytecode"
+url="https://github.com/google/enjarify"
+arch=('any')
+license=('Apache')
+depends=("python")
+makedepends=('git')
+checkdepends=('java-runtime')
+provides=('enjarify')
+conflicts=('enjarify')
+source=(${pkgname}::git+https://github.com/google/enjarify)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ printf "%s.%s.%s" "$(git describe --tags --abbrev=0|cut -dv -f2)" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${pkgname}
+ sed -r 's| -Xss515m||g' -i enjarify/runtests.py
+}
+
+build() {
+ cd ${pkgname}
+ python -m compileall .
+ python -O -m compileall .
+}
+
+check() {
+ cd ${pkgname}
+ LC_CTYPE=en_US.UTF-8 python -m enjarify.runtests
+}
+
+package() {
+ cd ${pkgname}
+ install -d "${pkgdir}/usr/lib/enjarify"
+ cp -R enjarify enjarify.sh "${pkgdir}/usr/lib/enjarify"
+ install -d "${pkgdir}/usr/bin"
+ ln -s /usr/lib/enjarify/enjarify.sh "${pkgdir}/usr/bin/enjarify"
+ install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+}
+
+# vim: ts=2 sw=2 et: