summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhalosghost2017-04-02 00:48:57 -0500
committerhalosghost2017-04-02 00:48:57 -0500
commitb0ccae91eec6989c691095fe70743305b3c10b51 (patch)
tree6f7f46f6cc915c5eee0fd62a9b0dfee69abf152b
downloadaur-b0ccae91eec6989c691095fe70743305b3c10b51.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..34fdede330e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Apr 2 05:48:46 UTC 2017
+pkgbase = enlighten-git
+ pkgdesc = A small tool to modify LCD backlight brightness
+ pkgver = 0
+ pkgrel = 1
+ url = https://github.com/HalosGhost/enlighten
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = tup
+ makedepends = clang
+ source = git+https://github.com/HalosGhost/enlighten.git
+ sha256sums = SKIP
+
+pkgname = enlighten-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..648c030c3c4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Sam Stuewe <halosghost at archlinux dot info>
+
+pkgname=enlighten-git
+pkgver=0
+pkgrel=1
+
+pkgdesc='A small tool to modify LCD backlight brightness'
+url='https://github.com/HalosGhost/enlighten'
+arch=('i686' 'x86_64')
+license=('GPL3')
+
+makedepends=('git' 'tup' 'clang')
+
+source=('git+https://github.com/HalosGhost/enlighten.git')
+sha256sums=('SKIP')
+
+pkgver () {
+ cd enlighten
+ printf '0.r%s.%s' "$(git rev-list --count HEAD)" "$(git log -1 --pretty=format:%h)"
+}
+
+prepare () {
+ cd enlighten
+ ./configure # --device=<see `ls /sys/class/backlight` for your device names>'
+}
+
+build () {
+ cd enlighten
+ make
+}
+
+package () {
+ cd enlighten
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+}