summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2023-10-03 21:54:25 +0200
committerChristopher Arndt2023-10-03 21:55:37 +0200
commit9c82198722e62d779539b4a7949ee81f3752b0f4 (patch)
tree5879c30d1713f114acf35013929642733ecaa91d
parentdb12b9d9f91906fd64ca2f62f2b458084ebef780 (diff)
downloadaur-9c82198722e62d779539b4a7949ee81f3752b0f4.tar.gz
Fix git local checkout
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD4
3 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7adef558e18..2e8b84757c9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ensemble-chorus-git
pkgdesc = An LV2/VST2 plugin and stand-alone application emulating a string ensemble chorus
pkgver = 0.0.1.r56.59baeb8
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jpcima/ensemble-chorus
arch = i686
arch = x86_64
@@ -34,4 +34,3 @@ pkgbase = ensemble-chorus-git
md5sums = a98866e03ccdebf93969755277c2712d
pkgname = ensemble-chorus-git
-
diff --git a/.gitignore b/.gitignore
index a77da735c1f7..6b6efa52e1e7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -8,5 +8,5 @@ rtaudio/
pkg/
src/
ensemble-chorus-git-*.src.tar.gz
-ensemble-chorus-git-*.tar.xz
+ensemble-chorus-git-*.pkg.tar.*
.AURINFO
diff --git a/PKGBUILD b/PKGBUILD
index 23234271b2d0..01a52cd194d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=ensemble-chorus
pkgname="${_pkgname}-git"
pkgver=0.0.1.r56.59baeb8
-pkgrel=1
+pkgrel=2
pkgdesc="An LV2/VST2 plugin and stand-alone application emulating a string ensemble chorus"
arch=('i686' 'x86_64')
url="https://github.com/jpcima/ensemble-chorus"
@@ -46,7 +46,7 @@ prepare() {
for submodule in DSPFilters gsl-lite rtaudio predef pugixml JUCE; do
git config submodule.thirdparty/${submodule}.url "${srcdir}/${submodule}"
done
- git submodule update
+ git -c protocol.file.allow=always submodule update
# https://github.com/WeAreROLI/JUCE/commit/4e0adb2af8b424c43d22bd431011c9a6c57d36b6.patch
( cd thirdparty/JUCE; patch -N -r - -p1 -i "${srcdir}/juce-pixel.patch" || exit 0; )