summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Legner2015-06-12 11:11:15 +0200
committerSimon Legner2015-06-12 11:11:15 +0200
commit760a34584862522c42085d176b9b7487a41f9864 (patch)
treefc8393f78518b87bbe46e51c8e06e62fb66792c6
downloadaur-760a34584862522c42085d176b9b7487a41f9864.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
-rw-r--r--entomologist.install11
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..accb8afe105e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = entomologist
+ pkgdesc = A desktop client for working with Bugzilla bugs across multiple trackers (Qt4)
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = https://github.com/Entomologist/entomologist
+ install = entomologist.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = qt4
+ source = https://github.com/Entomologist/entomologist/archive/27e2a66cc407e2ff2c165ad77ca6d9d88f5cd28e.zip
+ source = entomologist.install
+ md5sums = 5c9fc5a16b283e83d9e714ee63123bb2
+ md5sums = 0a8baf724d4c367eef70a46eb87b8d82
+ sha1sums = 9476cb04f72b95547fc4c711365770d9ca06bb49
+ sha1sums = 21368e92101389151fa171262f5ac6106ea10ab8
+
+pkgname = entomologist
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b44b687f8b22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Simon Legner <Simon.Legner@gmail.com>
+pkgname=entomologist
+pkgver=1.1.2
+_pkgver=27e2a66cc407e2ff2c165ad77ca6d9d88f5cd28e
+pkgrel=1
+pkgdesc="A desktop client for working with Bugzilla bugs across multiple trackers (Qt4)"
+arch=('i686' 'x86_64')
+url="https://github.com/Entomologist/entomologist"
+license=('GPL2')
+depends=('qt4')
+source=(https://github.com/Entomologist/${pkgname}/archive/${_pkgver}.zip entomologist.install)
+install=entomologist.install
+
+build() {
+ cd "$srcdir/$pkgname-$_pkgver/desktop"
+ qmake-qt4
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$_pkgver/desktop"
+ make INSTALL_ROOT="$pkgdir/" install
+}
+
+md5sums=('5c9fc5a16b283e83d9e714ee63123bb2'
+ '0a8baf724d4c367eef70a46eb87b8d82')
+sha1sums=('9476cb04f72b95547fc4c711365770d9ca06bb49'
+ '21368e92101389151fa171262f5ac6106ea10ab8')
diff --git a/entomologist.install b/entomologist.install
new file mode 100644
index 000000000000..2c455e952b7b
--- /dev/null
+++ b/entomologist.install
@@ -0,0 +1,11 @@
+post_install() {
+ xdg-icon-resource forceupdate
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}