summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Damm2017-12-02 21:17:08 +0100
committerStefan Damm2017-12-02 21:17:08 +0100
commit25d1d33af104fc7eba79b4d4b78058e9ded56a43 (patch)
tree57c4ba058d7ee49d1fb7b572c2e78eea6078df68
downloadaur-25d1d33af104fc7eba79b4d4b78058e9ded56a43.tar.gz
Initial PKGBUILD for entropy-piano-tuner
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD38
-rw-r--r--rpath.patch13
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a51a267dc246
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = entropy-piano-tuner
+ pkgdesc = Free Software for Piano Tuning
+ pkgver = git
+ pkgrel = 1
+ url = https://gitlab.com/tp3/Entropy-Piano-Tuner
+ arch = x86
+ arch = x86_64
+ license = GPL3
+ depends = qtmidi-qt5
+ depends = qwt
+ depends = libuv
+ depends = hicolor-icon-theme
+ depends = qt5-multimedia
+ depends = fftw
+ source = git+https://gitlab.com/tp3/Entropy-Piano-Tuner.git
+ source = rpath.patch
+ md5sums = SKIP
+ md5sums = e7f34645ebe707be6d417f1f4bc31ebd
+
+pkgname = entropy-piano-tuner
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d132737b58f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Stefan Damm <autama@nurfuerspam.de>
+pkgname=entropy-piano-tuner
+pkgver=git
+pkgrel=1
+pkgdesc="Free Software for Piano Tuning"
+arch=('i686' 'x86_64')
+url="https://gitlab.com/tp3/Entropy-Piano-Tuner"
+license=('GPL3')
+depends=('qtmidi-qt5' 'qwt' 'libuv' 'hicolor-icon-theme' 'qt5-multimedia' 'fftw')
+
+source=(git+https://gitlab.com/tp3/Entropy-Piano-Tuner.git rpath.patch)
+md5sums=('SKIP'
+ 'e7f34645ebe707be6d417f1f4bc31ebd')
+
+prepare() {
+ cd Entropy-Piano-Tuner
+ patch -Np1 -i ../rpath.patch
+}
+
+build() {
+ cd "Entropy-Piano-Tuner"
+ git submodule update --init
+
+ rm -rf build
+ mkdir build
+ cd build
+
+ qmake-qt5 -r .. "PKGDIR=$pkgdir/" "EPT_INSTALL_BIN_RDIR=usr/bin" "EPT_INSTALL_DATA_RDIR=usr/share" "EPT_INSTALL_LIB_RDIR=usr/lib"
+ make -j
+}
+
+package() {
+ cd "Entropy-Piano-Tuner/build"
+
+ make install
+
+ echo "Test"
+}
diff --git a/rpath.patch b/rpath.patch
new file mode 100644
index 000000000000..b531b1c3ff41
--- /dev/null
+++ b/rpath.patch
@@ -0,0 +1,13 @@
+diff --git a/app/app.pro b/app/app.pro
+index 78f9f6d..2b357ef 100644
+--- a/app/app.pro
++++ b/app/app.pro
+@@ -420,7 +420,7 @@ RESOURCES += \
+
+ contains(EPT_CONFIG, install) {
+ # add the install dir for the core the the rpath
+- unix:QMAKE_RPATHDIR += $$EPT_INSTALL_LIB_RDIR/entropypianotuner
++ unix:QMAKE_RPATHDIR += "/$$EPT_INSTALL_LIB_RDIR/entropypianotuner"
+
+ target.path = $$EPT_INSTALL_BIN_DIR
+