summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Meunier2019-05-17 19:58:44 +0200
committerGuillaume Meunier2019-05-17 19:58:44 +0200
commit730a5c4831f12bcc31f7d06ec5b34183ebf7a341 (patch)
treef48c8119d200eaad35eb477a5814572641bc44b4
parent9c1c01f508b4baba3aef9885285596f296d3d5c4 (diff)
downloadaur-730a5c4831f12bcc31f7d06ec5b34183ebf7a341.tar.gz
Version 3.0.0
-rw-r--r--.SRCINFO8
-rw-r--r--7c5019c30fc463c13c8a20f54c894aac908ebd56.patch32
-rw-r--r--PKGBUILD22
3 files changed, 6 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06778e0a083b..1669a5206374 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = entt
pkgdesc = A header-only, tiny and easy to use entity-component system (and much more) written in modern C++
- pkgver = 2.7.3
+ pkgver = 3.0.0
pkgrel = 1
url = https://skypjack.github.io/entt/
arch = any
license = MIT
makedepends = cmake
- source = https://github.com/skypjack/entt/archive/v2.7.3.tar.gz
- source = https://github.com/skypjack/entt/commit/7c5019c30fc463c13c8a20f54c894aac908ebd56.patch
- sha256sums = 81227bc7170d6d03371059f0a5167e706831459b72bbc35022fe87cb36854faa
- sha256sums = 7f29e54eb89343dce32a7c929a57501f55d4a01456d8aaf2a74c53f05de10406
+ source = https://github.com/skypjack/entt/archive/v3.0.0.tar.gz
+ sha256sums = f8928314a18f1fabda5398efdef7a001d09de43c2ffda90c1b77e56f5d41574b
pkgname = entt
diff --git a/7c5019c30fc463c13c8a20f54c894aac908ebd56.patch b/7c5019c30fc463c13c8a20f54c894aac908ebd56.patch
deleted file mode 100644
index 190b2cd1b7fa..000000000000
--- a/7c5019c30fc463c13c8a20f54c894aac908ebd56.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 7c5019c30fc463c13c8a20f54c894aac908ebd56 Mon Sep 17 00:00:00 2001
-From: willtunnels <bendriscoll00@gmail.com>
-Date: Wed, 21 Nov 2018 08:44:06 -0800
-Subject: [PATCH] Fix find_package(EnTT) when EnTT is installed using vcpkg
- (#159)
-
-This commit fixes a bug where find_package(EnTT) fails when EnTT is
-installed using vcpkg.
-
-The bug occurs because EnTTConfig.cmake.in calls
-check_required_components(), yet the call to
-configure_package_config_file() in CMakeLists.txt that generates
-EnTTConfig.cmake is passed NO_CHECK_REQUIRED_COMPONENTS_MACRO. This
-causes CMake to error when it tries to parse the output EnTTConfig.cmake
-file if that file is generated from EnTTConfig.cmake.in e.g. when
-installing EnTT using vcpkg.
----
- CMakeLists.txt | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index cb60541..c68aec1 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -140,7 +140,6 @@ configure_package_config_file(
- ${CUSTOM_INSTALL_CONFIGDIR}/EnTTConfig.cmake
- INSTALL_DESTINATION ${CUSTOM_INSTALL_CONFIGDIR}
- PATH_VARS CMAKE_INSTALL_INCLUDEDIR
-- NO_CHECK_REQUIRED_COMPONENTS_MACRO
- )
-
- write_basic_package_version_file(
diff --git a/PKGBUILD b/PKGBUILD
index 80ca72b7d937..7ecf0167bef8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Guillaume Meunier <guillaume.meunier@centraliens.net>
pkgname=entt
pkgbase=entt
-pkgver=2.7.3
+pkgver=3.0.0
pkgrel=1
epoch=
pkgdesc="A header-only, tiny and easy to use entity-component system (and much more) written in modern C++"
@@ -18,27 +18,11 @@ options=()
install=
changelog=
-source=("https://github.com/skypjack/entt/archive/v$pkgver.tar.gz"
- "https://github.com/skypjack/entt/commit/7c5019c30fc463c13c8a20f54c894aac908ebd56.patch")
+source=("https://github.com/skypjack/entt/archive/v$pkgver.tar.gz")
noextract=()
-sha256sums=('81227bc7170d6d03371059f0a5167e706831459b72bbc35022fe87cb36854faa'
- '7f29e54eb89343dce32a7c929a57501f55d4a01456d8aaf2a74c53f05de10406')
+sha256sums=('f8928314a18f1fabda5398efdef7a001d09de43c2ffda90c1b77e56f5d41574b')
validpgpkeys=()
-prepare() {
- patch -d $pkgname-$pkgver -p1 < 7c5019c30fc463c13c8a20f54c894aac908ebd56.patch
-}
-
-# pkgver() {
-# cd "$_pkgname"
-#
-# (
-# set -o pipefail
-# git describe --long 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
-# printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-# )
-# }
-
build() {
mkdir -p build
cd build