summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Meunier2018-12-09 17:23:51 +0100
committerGuillaume Meunier2018-12-09 17:23:51 +0100
commit85a1f97a380714af9a445ea3ebd2ae69450c4e24 (patch)
treea74aeb5699bd8a38cf65c33a176b7b44ebffbf93
downloadaur-85a1f97a380714af9a445ea3ebd2ae69450c4e24.tar.gz
First commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD56
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd1fe6a0d272
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = entt
+ pkgdesc = A header-only, tiny and easy to use entity-component system (and much more) written in modern C++
+ pkgver = 2.7.3
+ pkgrel = 1
+ url = https://skypjack.github.io/entt/
+ arch = any
+ license = MIT
+ makedepends = cmake
+ source = https://github.com/skypjack/entt/archive/v2.7.3.tar.gz
+ sha256sums = 81227bc7170d6d03371059f0a5167e706831459b72bbc35022fe87cb36854faa
+
+pkgname = entt
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ad5a4af52e8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*~
+src/
+pkg/
+
+*.tar.gz
+*.pkg.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40b393ef8e13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Guillaume Meunier <guillaume.meunier@centraliens.net>
+pkgname=entt
+pkgbase=entt
+pkgver=2.7.3
+pkgrel=1
+epoch=
+pkgdesc="A header-only, tiny and easy to use entity-component system (and much more) written in modern C++"
+arch=('any')
+url="https://skypjack.github.io/entt/"
+license=('MIT')
+groups=()
+makedepends=(cmake)
+checkdepends=()
+optdepends=()
+conflicts=()
+backup=()
+options=()
+install=
+changelog=
+
+source=("https://github.com/skypjack/entt/archive/v$pkgver.tar.gz")
+noextract=()
+sha256sums=('81227bc7170d6d03371059f0a5167e706831459b72bbc35022fe87cb36854faa')
+validpgpkeys=()
+
+# prepare() {
+#
+# }
+
+# pkgver() {
+# cd "$_pkgname"
+#
+# (
+# set -o pipefail
+# git describe --long 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+# printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+# )
+# }
+
+build() {
+ mkdir -p build
+ cd build
+
+ cmake ../$pkgname-$pkgver -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DUSE_LIBCPP=OFF -DBUILD_TESTING=OFF -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+package() {
+
+ pushd build
+ DESTDIR="$pkgdir"/ make install
+ popd > /dev/null
+
+ mkdir -p "$pkgdir"/usr/share/licenses/$pkgbase
+ install $pkgname-$pkgver/LICENSE $pkgdir/usr/share/licenses/$pkgbase/
+}