summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Meunier2018-12-09 17:49:46 +0100
committerGuillaume Meunier2018-12-09 17:49:46 +0100
commitbfc4e16020b5610347d68d42a22cfc3877ce0fff (patch)
treefd1dbf5523ed6aafa708063b27ab9c821d6b524a
parent85a1f97a380714af9a445ea3ebd2ae69450c4e24 (diff)
downloadaur-bfc4e16020b5610347d68d42a22cfc3877ce0fff.tar.gz
Fix installed cmake file
-rw-r--r--7c5019c30fc463c13c8a20f54c894aac908ebd56.patch32
-rw-r--r--PKGBUILD12
2 files changed, 39 insertions, 5 deletions
diff --git a/7c5019c30fc463c13c8a20f54c894aac908ebd56.patch b/7c5019c30fc463c13c8a20f54c894aac908ebd56.patch
new file mode 100644
index 000000000000..190b2cd1b7fa
--- /dev/null
+++ b/7c5019c30fc463c13c8a20f54c894aac908ebd56.patch
@@ -0,0 +1,32 @@
+From 7c5019c30fc463c13c8a20f54c894aac908ebd56 Mon Sep 17 00:00:00 2001
+From: willtunnels <bendriscoll00@gmail.com>
+Date: Wed, 21 Nov 2018 08:44:06 -0800
+Subject: [PATCH] Fix find_package(EnTT) when EnTT is installed using vcpkg
+ (#159)
+
+This commit fixes a bug where find_package(EnTT) fails when EnTT is
+installed using vcpkg.
+
+The bug occurs because EnTTConfig.cmake.in calls
+check_required_components(), yet the call to
+configure_package_config_file() in CMakeLists.txt that generates
+EnTTConfig.cmake is passed NO_CHECK_REQUIRED_COMPONENTS_MACRO. This
+causes CMake to error when it tries to parse the output EnTTConfig.cmake
+file if that file is generated from EnTTConfig.cmake.in e.g. when
+installing EnTT using vcpkg.
+---
+ CMakeLists.txt | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index cb60541..c68aec1 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -140,7 +140,6 @@ configure_package_config_file(
+ ${CUSTOM_INSTALL_CONFIGDIR}/EnTTConfig.cmake
+ INSTALL_DESTINATION ${CUSTOM_INSTALL_CONFIGDIR}
+ PATH_VARS CMAKE_INSTALL_INCLUDEDIR
+- NO_CHECK_REQUIRED_COMPONENTS_MACRO
+ )
+
+ write_basic_package_version_file(
diff --git a/PKGBUILD b/PKGBUILD
index 40b393ef8e13..80ca72b7d937 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,14 +18,16 @@ options=()
install=
changelog=
-source=("https://github.com/skypjack/entt/archive/v$pkgver.tar.gz")
+source=("https://github.com/skypjack/entt/archive/v$pkgver.tar.gz"
+ "https://github.com/skypjack/entt/commit/7c5019c30fc463c13c8a20f54c894aac908ebd56.patch")
noextract=()
-sha256sums=('81227bc7170d6d03371059f0a5167e706831459b72bbc35022fe87cb36854faa')
+sha256sums=('81227bc7170d6d03371059f0a5167e706831459b72bbc35022fe87cb36854faa'
+ '7f29e54eb89343dce32a7c929a57501f55d4a01456d8aaf2a74c53f05de10406')
validpgpkeys=()
-# prepare() {
-#
-# }
+prepare() {
+ patch -d $pkgname-$pkgver -p1 < 7c5019c30fc463c13c8a20f54c894aac908ebd56.patch
+}
# pkgver() {
# cd "$_pkgname"