summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsnafu2018-01-17 16:54:03 +0100
committersnafu2018-01-17 16:54:03 +0100
commit0f3cbcd8ec15e9d8ca6ce005d83cb98173d5fbed (patch)
treec99a0707528193424fc882eff21d5485aa8b1322
parenta4d8e6d09a7f98efd8fa0eda2a80ffb0387e28c7 (diff)
downloadaur-0f3cbcd8ec15e9d8ca6ce005d83cb98173d5fbed.tar.gz
Version bump to 4.1.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--zshcomp.patch17
3 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc4416841145..65d5bb821cb7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = env-modules
pkgdesc = Provides for an easy dynamic modification of a user's environment via modulefile.
- pkgver = 4.0.0
+ pkgver = 4.1.0
pkgrel = 1
url = https://sourceforge.net/projects/modules/
install = env-modules.install
@@ -12,10 +12,10 @@ pkgbase = env-modules
conflicts = env-modules-tcl
replaces = env-modules-tcl
backup = etc/modules/init/modulerc
- source = https://sourceforge.net/projects/modules/files/Modules/modules-4.0.0/modules-4.0.0.tar.gz
+ source = https://sourceforge.net/projects/modules/files/Modules/modules-4.1.0/modules-4.1.0.tar.gz
source = zshcomp.patch
- md5sums = 454dba418b1556d2fd5de753fbbabe0b
- md5sums = 2c6c0e8095d624da825e9a2938de0582
+ md5sums = 8626844e7de49a321e658f9d485e546b
+ md5sums = 5b4c34fac86b88c96a092c5972afa1fe
pkgname = env-modules
diff --git a/PKGBUILD b/PKGBUILD
index 4430647472dc..136991923807 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: snafu
pkgname=env-modules
-pkgver=4.0.0
+pkgver=4.1.0
pkgrel=1
epoch=
pkgdesc="Provides for an easy dynamic modification of a user's environment via modulefile."
@@ -21,9 +21,8 @@ changelog=
source=("https://sourceforge.net/projects/modules/files/Modules/modules-$pkgver/modules-$pkgver.tar.gz" zshcomp.patch)
noextract=()
validpgpkeys=()
-md5sums=('454dba418b1556d2fd5de753fbbabe0b'
- '2c6c0e8095d624da825e9a2938de0582')
-
+md5sums=('8626844e7de49a321e658f9d485e546b'
+ '5b4c34fac86b88c96a092c5972afa1fe')
# Install locations:
install_prefix=/usr
@@ -55,7 +54,8 @@ build() {
--disable-set-manpath \
--enable-compat-version \
--enable-example-modulefiles \
- --enable-doc-install
+ --enable-doc-install \
+ --without-pager
make
}
diff --git a/zshcomp.patch b/zshcomp.patch
index 005ab066ce0d..9720da002efa 100644
--- a/zshcomp.patch
+++ b/zshcomp.patch
@@ -1,6 +1,7 @@
-diff -aur modules-4.0.0/init/zsh-functions/_module modules-4.0.0-patched/init/zsh-functions/_module
---- modules-4.0.0/init/zsh-functions/_module 2017-10-16 06:49:58.000000000 +0200
-+++ modules-4.0.0-patched/init/zsh-functions/_module 2017-11-01 17:58:13.771039301 +0100
+diff --git a/init/zsh-functions/_module b/init/zsh-functions/_module
+index 45042d1..a1c686a 100644
+--- a/init/zsh-functions/_module
++++ b/init/zsh-functions/_module
@@ -4,17 +4,35 @@
# Zsh command-line completion for module
# Copyright (C) 2017 Xavier Delaruelle <xavier.delaruelle@cea.fr>
@@ -47,7 +48,7 @@ diff -aur modules-4.0.0/init/zsh-functions/_module modules-4.0.0-patched/init/zs
}
_module_savelist() {
-@@ -24,18 +42,15 @@
+@@ -24,18 +42,15 @@ _module_savelist() {
/:ERROR:/d;'
}
@@ -71,7 +72,7 @@ diff -aur modules-4.0.0/init/zsh-functions/_module modules-4.0.0-patched/init/zs
_module_saved_colls() {
local -a saved_colls;
saved_colls=(${$(_module_savelist)})
-@@ -44,10 +59,8 @@
+@@ -44,10 +59,8 @@ _module_saved_colls() {
}
_module_notloaded_mods() {
@@ -83,12 +84,12 @@ diff -aur modules-4.0.0/init/zsh-functions/_module modules-4.0.0-patched/init/zs
}
_module_loaded_mods() {
-@@ -169,7 +182,7 @@
+@@ -177,7 +190,7 @@ _module() {
'*:modulepath:_files -/' && ret=0
;;
- (display|help|show|test|whatis)
+ (display|help|show|test|whatis|is-loaded|is-avail|info-loaded)
- _alternative 'avail-mods:modulefiles:{_module_avail_mods}' \
+ _alternative 'avail-mods:modulefiles:{_module_all_mods}' \
&& ret=0
;;
- esac
+ (append-path|prepend-path)