summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsnafu2019-02-08 16:31:59 +0100
committersnafu2019-02-08 16:34:30 +0100
commit1bb0bb3f52d8ac8a1d29f535367b7ab56d2e7b3d (patch)
tree8495cb9d7e6ab48d3c62c1f925856a523f2c28d3
parent84423104b6a9ba33d15279d5ead8d8aee564afe9 (diff)
downloadaur-1bb0bb3f52d8ac8a1d29f535367b7ab56d2e7b3d.tar.gz
bump to 4.2.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
-rw-r--r--env-modules.install24
3 files changed, 24 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb256c8cfd1c..46e83b29a5b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = env-modules
pkgdesc = Provides for an easy dynamic modification of a user's environment via modulefile.
- pkgver = 4.1.4
- pkgrel = 1
+ pkgver = 4.2.1
+ pkgrel = 0
url = https://sourceforge.net/projects/modules/
install = env-modules.install
arch = i686
@@ -9,12 +9,12 @@ pkgbase = env-modules
license = GPLv2
checkdepends = dejagnu
depends = tcl>=7.4
- conflicts = env-modules-tcl
- replaces = env-modules-tcl
+ conflicts = env-modules
+ replaces = env-modules
backup = etc/modules/init/modulerc
- source = https://sourceforge.net/projects/modules/files/Modules/modules-4.1.4/modules-4.1.4.tar.gz
+ source = https://sourceforge.net/projects/modules/files/Modules/modules-4.2.1/modules-4.2.1.tar.gz
source = zshcomp.patch
- md5sums = c19bff662003fad79f92a89b9ad47139
+ md5sums = f4710af570b07153c7571967441ea4fe
md5sums = 48195d9f1c157c17b5c07e3997739f9c
pkgname = env-modules
diff --git a/PKGBUILD b/PKGBUILD
index 149e63928bfd..6d98e93b9407 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: snafu
-pkgname=env-modules
-pkgver=4.1.4
-pkgrel=1
+pkgname=(env-modules)
+pkgver=4.2.1
+pkgrel=0
epoch=
pkgdesc="Provides for an easy dynamic modification of a user's environment via modulefile."
arch=('i686' 'x86_64')
@@ -13,15 +13,15 @@ makedepends=()
checkdepends=('dejagnu')
optdepends=()
provides=()
-conflicts=(env-modules-tcl)
-replaces=(env-modules-tcl)
+conflicts=(env-modules)
+replaces=(env-modules)
options=()
install=env-modules.install
changelog=
source=("https://sourceforge.net/projects/modules/files/Modules/modules-$pkgver/modules-$pkgver.tar.gz" zshcomp.patch)
noextract=()
validpgpkeys=()
-md5sums=('c19bff662003fad79f92a89b9ad47139'
+md5sums=('f4710af570b07153c7571967441ea4fe'
'48195d9f1c157c17b5c07e3997739f9c')
# Install locations:
@@ -36,15 +36,13 @@ backup=("${config_path:1}/${moduledir}/init/modulerc")
prepare() {
cd "modules-$pkgver"
- # uncomment if you don't won't the zsh-completion patch or if it doesn't work for you
+ # comment if you don't won't the zsh-completion patch or if it doesn't work for you
patch -p1 < ../zshcomp.patch
}
build() {
cd "modules-$pkgver"
-
- # heavy-weight default -- remove examples/docs
./configure \
--prefix=/usr \
--docdir=$install_prefix/share/doc/$moduledir \
@@ -73,8 +71,8 @@ package() {
_profiled="${pkgdir}${profiled}"
mkdir -p "$_profiled"
- ln -s ${config_path}/${moduledir}/init/profile-compat.csh $_profiled/env-modules.csh
- ln -s ${config_path}/${moduledir}/init/profile-compat.sh $_profiled/env-modules.sh
+ ln -s ${config_path}/${moduledir}/init/profile.csh $_profiled/env-modules.csh
+ ln -s ${config_path}/${moduledir}/init/profile.sh $_profiled/env-modules.sh
# Work around, since module needs <PREFIX>/init for autoinitialization
ln -s ..${config_path}/${moduledir}/init ${pkgdir}/usr/init
diff --git a/env-modules.install b/env-modules.install
index 17c24b7c32cb..af8725ec5518 100644
--- a/env-modules.install
+++ b/env-modules.install
@@ -1,20 +1,14 @@
post_install() {
- echo ""
- echo "WARN: This installs the C-Version of modules as default, which is there for compatibilty reasons."
- echo " You might consider to install env-modules-tcl (TCL-Version only), if you don't need the C-Version."
- echo " Otherwise you can switch to the TCL Version by changing the symlink in /etc/profile.d/env-modules.{sh,csh}"
- echo " or by unsetting the enviroment variable:"
- echo " unset MODULES_USE_COMPAT_VERSION"
- echo ""
- echo "INFO: ZSH: For the use of module-cmd in a none-login Z-shell enviroment"
- echo " the following entry should be added to the zshrc "
- echo " (or zshenv if the module-cmd should be available in shell-scripts)"
- echo ""
- echo " (( \${+functions[module]} )) || source /etc/modules/init/zsh"
- echo ""
- echo " Adapt /etc/modules/init/modulerc and add your modulefiles to the specified directories."
- echo ""
+ echo " "
+ echo " ZSH: For the use of module-cmd in a none-login Z-shell enviroment"
+ echo " the following entry should be added to the zshrc "
+ echo " (or zshenv if the module-cmd should be available in shell-scripts)"
+ echo " "
+ echo " (( \${+functions[module]} )) || source /etc/modules/init/zsh"
+ echo " "
+ echo " Adapt /etc/modules/init/modulerc and add your modulefiles to the specified directories."
+ echo " "
}
post_upgrade() {