summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsnafu2017-01-27 13:29:50 +0100
committersnafu2017-01-27 13:29:50 +0100
commit213b23f75dfc03d4e7928b7432fc5d101157cc27 (patch)
tree468c5456e69e669efcfb1286bfef1382e6666a55
downloadaur-213b23f75dfc03d4e7928b7432fc5d101157cc27.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD50
-rw-r--r--modules.sh10
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0b278771697b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Jan 27 12:29:05 UTC 2017
+pkgbase = env-modules
+ pkgdesc = Provides for an easy dynamic modification of a user's environment via modulefile.
+ pkgver = 3.2.10
+ pkgrel = 1
+ url = https://sourceforge.net/projects/modules/
+ arch = i686
+ arch = x86_64
+ license = GPLv2
+ depends = tcl>=7.4
+ source = https://sourceforge.net/projects/modules/files/Modules/modules-3.2.10/modules-3.2.10.tar.gz
+ source = modules.sh
+ md5sums = 8b097fdcb90c514d7540bb55a3cb90fb
+ md5sums = 10c1cef6604a2a5e276ba34a9ed4b453
+
+pkgname = env-modules
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0846c2879c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=env-modules
+pkgver=3.2.10
+pkgrel=1
+epoch=
+pkgdesc="Provides for an easy dynamic modification of a user's environment via modulefile."
+arch=('i686' 'x86_64')
+url="https://sourceforge.net/projects/modules/"
+license=('GPLv2')
+groups=()
+depends=('tcl>=7.4')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+
+source=("https://sourceforge.net/projects/modules/files/Modules/modules-$pkgver/modules-$pkgver.tar.gz" modules.sh)
+noextract=()
+md5sums=('8b097fdcb90c514d7540bb55a3cb90fb'
+ '10c1cef6604a2a5e276ba34a9ed4b453')
+validpgpkeys=()
+
+
+build() {
+ cd "modules-$pkgver"
+ CPPFLAGS="-DUSE_INTERP_ERRORLINE" ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "modules-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "modules-$pkgver"
+ make DESTDIR="$pkgdir/" install
+
+ ln -s $pkgver ${pkgdir}/usr/Modules/default
+ _profiled="$pkgdir/etc/profile.d/"
+ mkdir -p "$_profiled"
+ ln -sf /usr/Modules/default/init/csh $_profiled/modules.csh
+ cp $srcdir/modules.sh $_profiled/modules.sh
+}
diff --git a/modules.sh b/modules.sh
new file mode 100644
index 000000000000..279af7864080
--- /dev/null
+++ b/modules.sh
@@ -0,0 +1,10 @@
+
+# init module enviroment
+
+if [[ -n $BASH_VERSION ]]; then
+ source /usr/Modules/default/init/bash
+elif [[ -n $ZSH_VERSION ]]; then
+ source /usr/Modules/default/init/zsh
+fi
+
+