summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsnafu2017-03-22 08:58:26 +0100
committersnafu2017-03-22 08:58:26 +0100
commit5085f4cc49e28c05f68b1f87956239cc35c1f782 (patch)
tree7e83cc5d90c42f9f06d465b66ddae9f5913e88f4
parent213b23f75dfc03d4e7928b7432fc5d101157cc27 (diff)
downloadaur-5085f4cc49e28c05f68b1f87956239cc35c1f782.tar.gz
fixes
-rw-r--r--PKGBUILD7
-rw-r--r--modules.sh4
2 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e0846c2879c0..209eb7a31fb9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,9 +8,9 @@ arch=('i686' 'x86_64')
url="https://sourceforge.net/projects/modules/"
license=('GPLv2')
groups=()
-depends=('tcl>=7.4')
+depends=('tcl>=7.4' 'procps-ng')
makedepends=()
-checkdepends=()
+checkdepends=('dejagnu')
optdepends=()
provides=()
conflicts=()
@@ -23,10 +23,9 @@ changelog=
source=("https://sourceforge.net/projects/modules/files/Modules/modules-$pkgver/modules-$pkgver.tar.gz" modules.sh)
noextract=()
md5sums=('8b097fdcb90c514d7540bb55a3cb90fb'
- '10c1cef6604a2a5e276ba34a9ed4b453')
+ '38e1de45377a991380602f2c011ec306')
validpgpkeys=()
-
build() {
cd "modules-$pkgver"
CPPFLAGS="-DUSE_INTERP_ERRORLINE" ./configure --prefix=/usr
diff --git a/modules.sh b/modules.sh
index 279af7864080..d189fda1c37a 100644
--- a/modules.sh
+++ b/modules.sh
@@ -1,9 +1,9 @@
# init module enviroment
-if [[ -n $BASH_VERSION ]]; then
+if [[ `ps -hp $$ | awk '{print $5}'` = "bash" ]]; then
source /usr/Modules/default/init/bash
-elif [[ -n $ZSH_VERSION ]]; then
+elif [[ `ps -hp $$ | awk '{print $5}'` = "zsh" ]]; then
source /usr/Modules/default/init/zsh
fi