summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsnafu2017-05-08 00:19:24 +0200
committersnafu2017-05-08 00:19:24 +0200
commit145fcf7bcdce8a6ca3e7a00f627f84dfdce02fdc (patch)
tree491359bcfdb58fe956ea6f945c2d10436d0b52b6
parent40c7978783c3118ece0a354fe45893271ef9d477 (diff)
downloadaur-145fcf7bcdce8a6ca3e7a00f627f84dfdce02fdc.tar.gz
zsh-quotes in subcommands
-rw-r--r--PKGBUILD2
-rw-r--r--zshcomp.patch4
2 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f46f03b23e95..239c04a1e095 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,7 @@ noextract=()
validpgpkeys=()
install="env-modules-tcl.install"
md5sums=('3a40bf6177cc438481672ce028544828'
- '4b7a5d66a1668fac5b3837723edceea4')
+ 'da8f7f9fc4e462b0ec0a6fab5257d8e0')
install_prefix=/usr
diff --git a/zshcomp.patch b/zshcomp.patch
index aae7debcca3d..d27e5c45a480 100644
--- a/zshcomp.patch
+++ b/zshcomp.patch
@@ -11,12 +11,12 @@
+function _module_completion () {
+ local _module_path_prefix
+ local -a _module_search_path _module_type_d _module_type_f
-+ _module_path_prefix=$(echo ${words[$CURRENT]} | sed -ne 's#\(.*/\).*#\1#p')
++ _module_path_prefix=$(echo ${(q)words[$CURRENT]} | sed -ne 's#\(.*/\).*#\1#p')
+ _module_search_paths=(${^${(@s/:/)MODULEPATH}}/$_module_path_prefix)
+
+ _module_type_d=()
+ _module_type_f=()
-+ eval $(find $_module_search_paths -mindepth 1 -maxdepth 1 -not -name '.modulerc' -not -name '.version' -printf "_module_type_%Y+=${_module_path_prefix}%P\n" 2> /dev/null)
++ eval $(find $_module_search_paths -mindepth 1 -maxdepth 1 -not -name '.modulerc' -not -name '.version' -printf "_module_type_%Y+=${(q)_module_path_prefix}%P\n" 2> /dev/null)
+
+ if [[ "$@" != "dir" ]]; then
+ compadd -q -S / ${_module_type_d}