summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsnafu2017-11-10 09:55:30 +0100
committersnafu2017-11-10 09:55:30 +0100
commit1c10a1f4ae5e39358ac0a04c53c03d5364ed1aaf (patch)
tree8ba6a7a8e90610ce0fc5bd2e2224df8a849d55dd
parentb357f3d14e41f1c4d21cec44f08aaf3097ed9c56 (diff)
downloadaur-1c10a1f4ae5e39358ac0a04c53c03d5364ed1aaf.tar.gz
* compat fixes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a625392713f..71ec63ed1577 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = env-modules-tcl
pkgdesc = Provides for an easy dynamic modification of a user's environment via modulefile.
pkgver = 4.0.0
- pkgrel = 0
+ pkgrel = 1
url = https://sourceforge.net/projects/modules/
install = env-modules-tcl.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 33d70fec9089..23b0a77b8c16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: snafu
pkgname=env-modules-tcl
pkgver=4.0.0
-pkgrel=0
+pkgrel=1
epoch=
pkgdesc="Provides for an easy dynamic modification of a user's environment via modulefile."
arch=('i686' 'x86_64')
@@ -74,5 +74,12 @@ package() {
mkdir -p "$_profiled"
ln -s ${config_path}/${moduledir}/init/profile.csh $_profiled/env-modules.csh
ln -s ${config_path}/${moduledir}/init/profile.sh $_profiled/env-modules.sh
+
+ # Work around, since module needs <PREFIX>/init for autoinitialization
+ ln -s ${config_path}/${moduledir}/init ${pkgdir}/usr/init
+
+ # Keep up with old versions:
+ ln -s ${config_path}/${moduledir}/init/perl.pm ${pkgdir}${config_path}/${moduledir}/init/perl
+ ln -s ${config_path}/${moduledir}/init/python.py ${pkgdir}${config_path}/${moduledir}/init/phyon
}