summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBao Trinh2023-05-23 07:10:59 -0500
committerBao Trinh2023-05-23 07:10:59 -0500
commitc20f7333951432630c2b7cde2ae870ff9eda1dd8 (patch)
tree42c3adb5462ba123eeaf479c8e8831466eab6f17
parent28531912422cf5554ddb448ebe61fd9d50afe37d (diff)
downloadaur-envconsul.tar.gz
v0.13.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--envconsul.changelog5
3 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2993753a9079..8a5cf91faab3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = envconsul
pkgdesc = Launch a subprocess with environment variables using data from @HashiCorp Consul and Vault.
- pkgver = 0.13.1
+ pkgver = 0.13.2
pkgrel = 2
url = https://github.com/hashicorp/envconsul
changelog = envconsul.changelog
@@ -11,7 +11,7 @@ pkgbase = envconsul
license = MPL2
makedepends = go
depends = glibc
- source = envconsul-0.13.1.tar.gz::https://github.com/hashicorp/envconsul/archive/v0.13.1/venvconsul-0.13.1.tar.gz
- sha512sums = 69a82bc7f1f50a274824ec02598b7bcd54197b29f073ffe72c1ea0604c084d53f5e68522b59c9709fc3227d17544426de1bce52176fbcf4a9b5b333f88599731
+ source = envconsul-0.13.2.tar.gz::https://github.com/hashicorp/envconsul/archive/v0.13.2/venvconsul-0.13.2.tar.gz
+ sha512sums = dacc65e19553de897195397126664882e3dedd4b9929c83c519311010ff1ab62663425556261a2ce3f37035576b63b4f26c4a0219dfd663d05e852c4cee2e6bb
pkgname = envconsul
diff --git a/PKGBUILD b/PKGBUILD
index b75c2f0e886a..3e82a75ed02c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bao Trinh <qubidt@gmail.com>
# Contributor: Jonatan Bravo <zephrax@gmail.com>
pkgname=envconsul
-pkgver=0.13.1
+pkgver=0.13.2
pkgrel=2
pkgdesc="Launch a subprocess with environment variables using data from @HashiCorp Consul and Vault."
arch=('i686' 'x86_64' 'arm' 'aarch64')
@@ -11,7 +11,7 @@ depends=('glibc')
makedepends=('go')
changelog="${pkgname}.changelog"
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}/v${pkgname}-${pkgver}.tar.gz")
-sha512sums=('69a82bc7f1f50a274824ec02598b7bcd54197b29f073ffe72c1ea0604c084d53f5e68522b59c9709fc3227d17544426de1bce52176fbcf4a9b5b333f88599731')
+sha512sums=('dacc65e19553de897195397126664882e3dedd4b9929c83c519311010ff1ab62663425556261a2ce3f37035576b63b4f26c4a0219dfd663d05e852c4cee2e6bb')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -52,5 +52,5 @@ package() {
cd "${pkgname}-${pkgver}"
install -Dm755 "build/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" README.md
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" README.md
}
diff --git a/envconsul.changelog b/envconsul.changelog
index a897365a09f6..a7df3a3734bb 100644
--- a/envconsul.changelog
+++ b/envconsul.changelog
@@ -1,4 +1,7 @@
-## envconsul CHANGELOG
+## v0.13.2 (May 22, 2023)
+
+SECURITY:
+* Update dependencies to address CVE-2022-41723.
## v0.13.1 (Oct 03, 2022)