summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBao Trinh2023-04-03 19:40:29 -0500
committerBao Trinh2023-04-03 19:40:29 -0500
commita7a3e47d0fa40a85bfcdddbe93d59b795e0fafdf (patch)
tree21f36a6073a08c30c36b7d7830aa4102ab0025c2
parentc5d87ac4a06003ec5158e4cd5bffa043a1c81f22 (diff)
downloadaur-a7a3e47d0fa40a85bfcdddbe93d59b795e0fafdf.tar.gz
fixes: tests, debug, docs
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD25
2 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3df04acb771..2993753a9079 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,16 @@
pkgbase = envconsul
pkgdesc = Launch a subprocess with environment variables using data from @HashiCorp Consul and Vault.
pkgver = 0.13.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/hashicorp/envconsul
changelog = envconsul.changelog
- arch = any
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = aarch64
license = MPL2
makedepends = go
+ depends = glibc
source = envconsul-0.13.1.tar.gz::https://github.com/hashicorp/envconsul/archive/v0.13.1/venvconsul-0.13.1.tar.gz
sha512sums = 69a82bc7f1f50a274824ec02598b7bcd54197b29f073ffe72c1ea0604c084d53f5e68522b59c9709fc3227d17544426de1bce52176fbcf4a9b5b333f88599731
diff --git a/PKGBUILD b/PKGBUILD
index d6445607d75e..5c75eccda5a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
# Contributor: Jonatan Bravo <zephrax@gmail.com>
pkgname=envconsul
pkgver=0.13.1
-pkgrel=1
+pkgrel=2
pkgdesc="Launch a subprocess with environment variables using data from @HashiCorp Consul and Vault."
-arch=('any')
+arch=('i686' 'x86_64' 'arm' 'aarch64')
url="https://github.com/hashicorp/envconsul"
license=('MPL2')
+depends=('glibc')
makedepends=('go')
changelog="${pkgname}.changelog"
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/hashicorp/${pkgname}/archive/v${pkgver}/v${pkgname}-${pkgver}.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}/v${pkgname}-${pkgver}.tar.gz")
sha512sums=('69a82bc7f1f50a274824ec02598b7bcd54197b29f073ffe72c1ea0604c084d53f5e68522b59c9709fc3227d17544426de1bce52176fbcf4a9b5b333f88599731')
prepare() {
@@ -23,32 +24,30 @@ prepare() {
}
build() {
- export CGO_CPPFLAGS="${CPPFLAGS}"
+ cd "${pkgname}-${pkgver}"
+ export CGO_LDFLAGS="${LDFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
-
- cd "${pkgname}-${pkgver}"
-
+ export GOPATH="${srcdir}"
go build \
- -trimpath \
-buildmode=pie \
-mod=readonly \
-modcacherw \
- -ldflags "-linkmode external -extldflags ${LDFLAGS}" \
+ -ldflags="-linkmode=external -compressdwarf=false" \
-o build \
.
}
check() {
cd "${pkgname}-${pkgver}"
-
- # run go tests
- # TODO: currently failling one test
- # go test -v ./...
+ export GOFLAGS="-ldflags=-linkmode=external"
+ go test -v ./...
}
package() {
cd "${pkgname}-${pkgver}"
install -Dm755 "build/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" README.md
}