summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrédéric Ruffet2019-11-28 15:20:10 +0100
committerFrédéric Ruffet2019-11-28 15:20:10 +0100
commitb6f86615b465e996ccab7fe8d00e2d87ec286d6c (patch)
tree7632b49ea8758b7558966f1f034b1b1c0418c251
parent7a219f38c9c8add0da8b08d3c59cd27453c7d8bd (diff)
downloadaur-b6f86615b465e996ccab7fe8d00e2d87ec286d6c.tar.gz
trying to fix permissions issues
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8762994c4262..66d52939f746 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ _pkgname=envconsul
pkgname=${_pkgname}-git
_pkgver=0.9.1
pkgver=v${_pkgver}
-pkgrel=2
+pkgrel=3
pkgdesc="Launch a subprocess with environment variables using data from @hashicorp Consul and Vault."
arch=('any')
url="https://github.com/hashicorp/envconsul.git"
@@ -14,10 +14,11 @@ source=("https://github.com/hashicorp/${_pkgname}/archive/${pkgver}.tar.gz")
md5sums=('SKIP')
prepare() {
+ umask 022
+ chmod -R u+w .
mkdir -p ${_pkgname}-${_pkgver}/gopath
export GOPATH="${srcdir}/${_pkgname}-${_pkgver}/gopath"
export PATH="$PATH:$GOPATH/bin"
- chmod -R u+w ${srcdir}
}
build() {