summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2021-08-14 00:19:43 -0300
committerTércio Martins2021-08-14 00:19:43 -0300
commit4c4a01e2063b32ff58b7e66e530a8c7ad2168f63 (patch)
treef8dfd5babe4457a0202b243cda3d732e37d6e247
parent1424ecf9f15a4d52936638707da32d8449dcf4ae (diff)
downloadaur-4c4a01e2063b32ff58b7e66e530a8c7ad2168f63.tar.gz
Fix build problem (failure to detect quazip library)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD28
2 files changed, 15 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ebe0c1c5710..a6d81cca4f48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = enve-git
pkgdesc = 2D animation software
pkgver = continuous.linux.r52.gc39be6f4
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://maurycyliebner.github.io/
arch = i686
@@ -18,18 +18,18 @@ pkgbase = enve-git
depends = qt5-multimedia
depends = qt5-svg
depends = qt5-webengine
+ depends = qscintilla-qt5
+ depends = quazip
source = git+https://github.com/MaurycyLiebner/enve.git
source = git+https://github.com/gperftools/gperftools.git
source = git+https://github.com/mypaint/libmypaint.git
source = git+https://skia.googlesource.com/skia.git
- source = git+https://github.com/opencor/qscintilla.git
source = enve-QPainterPath.patch
source = enve-skia-deps-python3.patch
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
- sha512sums = SKIP
sha512sums = a6ec4054ee0b91a02e99e8dcd0dab08afe0d72bb00065b9df3425081247be37da25635e7b9faf55039e380582c0a40a3ff73b79f29df0c7d6c7c45b8117c3ad6
sha512sums = 527906079ac8d14837acb78f750c60bee212976e2e335e58777db5e563b76f8288cc6f50259512e3fe2789b47e4101ed8e6c616ee193c6a547ecf13e89787907
diff --git a/PKGBUILD b/PKGBUILD
index a02a407ae99e..5078972d2f72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,24 @@
pkgname=enve-git
_pkgname=${pkgname%-git}
pkgver=continuous.linux.r52.gc39be6f4
-pkgrel=1
+pkgrel=2
epoch=1
arch=('i686' 'pentium4' 'x86_64')
pkgdesc="2D animation software"
url="https://maurycyliebner.github.io/"
license=('GPL3')
-depends=('gperftools' 'qt5-multimedia' 'qt5-svg' 'qt5-webengine')
+depends=('gperftools' 'qt5-multimedia' 'qt5-svg' 'qt5-webengine' 'qscintilla-qt5' 'quazip')
makedepends=('git' 'gn' 'intltool' 'ninja' 'openmp' 'python')
source=("git+https://github.com/MaurycyLiebner/enve.git"
"git+https://github.com/gperftools/gperftools.git"
"git+https://github.com/mypaint/libmypaint.git"
"git+https://skia.googlesource.com/skia.git"
- "git+https://github.com/opencor/qscintilla.git"
"enve-QPainterPath.patch"
"enve-skia-deps-python3.patch")
sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
'a6ec4054ee0b91a02e99e8dcd0dab08afe0d72bb00065b9df3425081247be37da25635e7b9faf55039e380582c0a40a3ff73b79f29df0c7d6c7c45b8117c3ad6'
'527906079ac8d14837acb78f750c60bee212976e2e335e58777db5e563b76f8288cc6f50259512e3fe2789b47e4101ed8e6c616ee193c6a547ecf13e89787907')
@@ -37,13 +35,21 @@ prepare() {
git submodule init
git config submodule.third_party/gperftools.url $srcdir/gperftools
git config submodule.third_party/libmypaint.url $srcdir/libmypaint
- git config submodule.third_party/qscintilla.url $srcdir/qscintilla
git config submodule.third_party/skia.url $srcdir/skia
git submodule update
# Patching enve source code
patch --forward --strip=1 --input="$srcdir/enve-QPainterPath.patch"
- sed -i 's|libmypaint/||g' src/core/libmypaintincludes.h
+ sed -i 's|libmypaint/||g' \
+ src/core/libmypaintincludes.h
+
+ # Change include directories
+ sed -i 's|$$THIRD_PARTY_FOLDER/qscintilla/Qt4Qt5|/usr/include/qt|' \
+ src/app/app.pro
+ sed -i "s|\$\$THIRD_PARTY_FOLDER/quazip|$(pacman -Ql quazip | cut -d ' ' -f 2 | grep -i include\/quazip | head -1 | sed 's|\/$||')|" \
+ src/core/core.pri
+ sed -i "s|-L\$\$QUAZIP_FOLDER/.*|$(pacman -Ql quazip | cut -d ' ' -f 2 | grep -i lib\/*quazip | head -1)|" \
+ src/core/core.pri
cd third_party
@@ -88,22 +94,12 @@ build() {
make
unset CFLAGS
- # Build quazip
- cd "$_third_party_dir/quazip"
- qmake quazip.pro CONFIG+=Release
- make
-
# Build gperftools
cd "$_third_party_dir/gperftools"
./autogen.sh
./configure --prefix=/usr LIBS=-lpthread
make
- # Build qscintilla
- cd "$_third_party_dir/qscintilla"
- qmake Qt4Qt5/qscintilla.pro CONFIG+=Release
- make
-
# Build enve
cd "$srcdir/$_pkgname/build/Release"
qmake ../../enve.pro \