summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-13 10:09:15 +0800
committerzxp198210052024-03-13 10:09:15 +0800
commitf06141cb880e80b0ca25e88370f413a71a7bf41b (patch)
tree60a8ebb7a7614aaff9319ae7ade7f99c5b8aa891
downloadaur-f06141cb880e80b0ca25e88370f413a71a7bf41b.tar.gz
update to 2.4.18
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD54
-rw-r--r--envkey-desktop.sh16
3 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40679b7bad5e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = envkey-desktop-bin
+ pkgdesc = Secure, human-friendly, cross-platform secrets and config.
+ pkgver = 2.4.18
+ pkgrel = 1
+ url = https://www.envkey.com/
+ arch = x86_64
+ license = MIT
+ makedepends = fuse2
+ depends = electron13-bin
+ depends = hicolor-icon-theme
+ depends = nodejs
+ depends = libsecret
+ provides = envkey-desktop=2.4.18
+ conflicts = envkey-desktop
+ source = envkey-desktop-2.4.18.AppImage::https://envkey-releases.s3.amazonaws.com/desktop/release_artifacts/2.4.18/EnvKey-2.4.18.AppImage
+ source = LICENSE-2.4.18::https://raw.githubusercontent.com/envkey/envkey/desktop-v2.4.18/LICENSE
+ source = envkey-desktop.sh
+ sha256sums = ad009fa2339c4ecde7fd7371a0dafa3a9ae0f85aa08df9d6b832298f0cb5aa72
+ sha256sums = d3e78cbc2e92dfabac2dc9c8a5cd22e702cba2a65455c265e5bed3a1d447a704
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
+
+pkgname = envkey-desktop-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5fe1be11ec7e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+_appname=envkey
+pkgname="${_appname}-desktop-bin"
+_pkgname=EnvKey
+pkgver=2.4.18
+_electronversion=13
+pkgrel=1
+pkgdesc="Secure, human-friendly, cross-platform secrets and config."
+arch=('x86_64')
+url="https://www.envkey.com/"
+_ghurl="https://github.com/envkey/envkey"
+_dlurl="https://envkey-releases.s3.amazonaws.com/desktop"
+license=('MIT')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=(
+ "electron${_electronversion}-bin"
+ 'hicolor-icon-theme'
+ 'nodejs'
+ 'libsecret'
+)
+makedepends=(
+ 'fuse2'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.AppImage::${_dlurl}/release_artifacts/${pkgver}/${_pkgname}-${pkgver}.AppImage"
+ "LICENSE-${pkgver}::https://raw.githubusercontent.com/envkey/envkey/desktop-v${pkgver}/LICENSE"
+ "${pkgname%-bin}.sh"
+)
+sha256sums=('ad009fa2339c4ecde7fd7371a0dafa3a9ae0f85aa08df9d6b832298f0cb5aa72'
+ 'd3e78cbc2e92dfabac2dc9c8a5cd22e702cba2a65455c265e5bed3a1d447a704'
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
+build() {
+ chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
+ "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
+ sed "s|AppRun --no-sandbox|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${_appname}.desktop"
+ find "${srcdir}/squashfs-root/resources" -type d -exec chmod 755 {} \;
+}
+package() {
+ sed -e "s|@electronversion@|${_electronversion}|g" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@runname@|app|g" \
+ -e "s|@options@||g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm755 -d "${pkgdir}/usr/lib/${pkgname%-bin}"
+ cp -r "${srcdir}/squashfs-root/resources/app" "${pkgdir}/usr/lib/${pkgname%-bin}"
+ for _icons in 16x16 32x32 48x48 64x64 128x128 256x256 512x512;do
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/${_appname}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png"
+ done
+ install -Dm644 "${srcdir}/squashfs-root/${_appname}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ install -Dm644 "${srcdir}/LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+} \ No newline at end of file
diff --git a/envkey-desktop.sh b/envkey-desktop.sh
new file mode 100644
index 000000000000..7ddcaab8d734
--- /dev/null
+++ b/envkey-desktop.sh
@@ -0,0 +1,16 @@
+#!/bin/bash
+set -e
+_APPDIR="/usr/lib/@appname@"
+_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
+export NODE_ENV=production
+cd "${_APPDIR}"
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
+else
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file