summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrei "Akari" Alexeyev2017-06-19 03:18:32 +0300
committerAndrei "Akari" Alexeyev2017-06-19 03:18:32 +0300
commit010e53da9a65185170d24d37fba162595dfd6ca2 (patch)
tree3ed1b3245dc4dcd7f8b9a32df85c46c0688263b5
downloadaur-010e53da9a65185170d24d37fba162595dfd6ca2.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..016386e7800a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = envlinkfs-git
+ pkgdesc = FUSE filesystem that exposes environment variables as symbolic links
+ pkgver = 0.1.r0.726bfaf
+ pkgrel = 1
+ url = https://github.com/Akaricchi/envlinkfs
+ arch = any
+ license = WTFPL
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = python-fusepy
+ provides = envlinkfs
+ conflicts = envlinkfs
+ source = git+https://github.com/Akaricchi/envlinkfs
+ md5sums = SKIP
+
+pkgname = envlinkfs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98c9d00f7ef0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Andrei Alexeyev <akari@alienslab.net>
+
+pkgname=envlinkfs-git
+pkgver=0.1.r0.726bfaf
+pkgrel=1
+pkgdesc="FUSE filesystem that exposes environment variables as symbolic links"
+arch=('any')
+url="https://github.com/Akaricchi/envlinkfs"
+license=('WTFPL')
+groups=()
+depends=('python' 'python-fusepy')
+makedepends=('git' 'python-setuptools')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://github.com/Akaricchi/envlinkfs')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --tags --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/${pkgname%-git}/COPYING"
+}