summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhai Zhaoxuan2018-11-01 16:30:22 +0800
committerZhai Zhaoxuan2018-11-01 16:30:22 +0800
commitc50d3884de1d0ad225cfe41d49fdd277cc851557 (patch)
tree5a0152e37b35f017f1cf873a63a587aa39ad5de8
downloadaur-c50d3884de1d0ad225cfe41d49fdd277cc851557.tar.gz
Initial commit
Signed-off-by: Zhai Zhaoxuan <zhaizhaoxuan@xiaomi.com>
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e8fab3ab0be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = envoyproxy
+ pkgdesc = A high performance, open source, general RPC framework that puts mobile and HTTP/2 first.
+ pkgver = 1.8.0
+ pkgrel = 1
+ url = https://envoyproxy.io
+ arch = i686
+ arch = x86_64
+ license = Apache2
+ makedepends = cmake
+ makedepends = clang
+ makedepends = go
+ makedepends = bazel
+ makedepends = perl
+ makedepends = ninja
+ makedepends = python
+ source = https://github.com/envoyproxy/envoy/archive/v1.8.0.tar.gz
+ sha512sums = 728794f755b85e2a01b79342156953deade38c34a565e538928cb669a17658af01b69488a0e966b4774bba6d30fa2d460e3329f80503a3de1f8669225bf4426b
+
+pkgname = envoyproxy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc52863e143e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: kXuan <kxuanobj@gmail.com>
+
+pkgname=envoyproxy
+pkgver=1.8.0
+pkgrel=1
+pkgdesc="A high performance, open source, general RPC framework that puts mobile and HTTP/2 first."
+arch=('i686' 'x86_64')
+url='https://envoyproxy.io'
+license=('Apache2')
+makedepends=('cmake' 'clang' 'go' 'bazel' 'perl' 'ninja' 'python')
+source=(
+ https://github.com/$pkgname/envoy/archive/v$pkgver.tar.gz
+)
+sha512sums=('728794f755b85e2a01b79342156953deade38c34a565e538928cb669a17658af01b69488a0e966b4774bba6d30fa2d460e3329f80503a3de1f8669225bf4426b')
+
+prepare() {
+ cd "envoy-$pkgver"
+ go get github.com/bazelbuild/buildtools/buildifier
+ echo "5d25f466c3410c0dfa735d7d4358beb76b2da507" > SOURCE_VERSION
+}
+
+build() {
+ cd "envoy-$pkgver"
+
+ bazel build --verbose_failures --workspace_status_command bazel/get_workspace_status //source/exe:envoy-static
+}
+
+package() {
+ cd "envoy-$pkgver"
+
+ install -Dm755 bazel-bin/source/exe/envoy-static "$pkgdir"/usr/bin/envoy
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}