summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkXuan2019-11-15 18:45:57 +0800
committerkXuan2019-11-15 18:45:57 +0800
commitcde07a3888383936cda816113b50e60e043853e6 (patch)
tree2bd1f96cd412795a4c0c8a1fcdfd2ce791c3b9be
parentecda24595dc773519ddc34ac2bf7e867891ff830 (diff)
downloadaur-cde07a3888383936cda816113b50e60e043853e6.tar.gz
fix commit id
Signed-off-by: kXuan <kxuanobj@gmail.com>
-rw-r--r--0001-Patch-in-ecf04cc-and-49f0fb9-from-gRPC.-7850.patch187
-rw-r--r--0002-bazel-patch-gRPC-to-fix-Envoy-builds-with-glibc-v2.3.patch124
-rw-r--r--0003-fix-com_github_datadog_dd_opentracing_cpp-build-fail.patch65
-rw-r--r--PKGBUILD2
4 files changed, 1 insertions, 377 deletions
diff --git a/0001-Patch-in-ecf04cc-and-49f0fb9-from-gRPC.-7850.patch b/0001-Patch-in-ecf04cc-and-49f0fb9-from-gRPC.-7850.patch
deleted file mode 100644
index 6a1d5703f52c..000000000000
--- a/0001-Patch-in-ecf04cc-and-49f0fb9-from-gRPC.-7850.patch
+++ /dev/null
@@ -1,187 +0,0 @@
-From 1dc418f6d7ff6402de3bbac2145f3e8e01562457 Mon Sep 17 00:00:00 2001
-From: lberki <lberki@users.noreply.github.com>
-Date: Wed, 14 Aug 2019 00:47:15 +0200
-Subject: [PATCH] Patch in ecf04cc and 49f0fb9 from gRPC. (#7850)
-
-This is so that Envoy keeps building with the --incompatible_disable_legacy_proto_provider command line option of Bazel which is to be flipped in 1.0 .
-
-Description:
-Risk Level:
-Testing:
-Docs Changes:
-Release Notes:
-
-Signed-off-by: Lukacs T. Berki <lberki@google.com>
----
- bazel/grpc-protoinfo-1.patch | 56 ++++++++++++++++++++++++++++++++++++
- bazel/grpc-protoinfo-2.patch | 32 +++++++++++++++++++++
- bazel/grpc-protoinfo-3.patch | 31 ++++++++++++++++++++
- bazel/repositories.bzl | 12 +++++++-
- 4 files changed, 130 insertions(+), 1 deletion(-)
- create mode 100644 bazel/grpc-protoinfo-1.patch
- create mode 100644 bazel/grpc-protoinfo-2.patch
- create mode 100644 bazel/grpc-protoinfo-3.patch
-
-diff --git a/bazel/grpc-protoinfo-1.patch b/bazel/grpc-protoinfo-1.patch
-new file mode 100644
-index 000000000..f91e7a035
---- /dev/null
-+++ b/bazel/grpc-protoinfo-1.patch
-@@ -0,0 +1,56 @@
-+commit 49f0fb9035120d0f5b5fa49846324c0b2d59c257
-+Author: Marcel Hlopko <hlopko@google.com>
-+Date: Thu Jun 20 18:55:56 2019 +0200
-+
-+ Migrate from dep.proto to dep[ProtoInfo]
-+
-+diff --git a/WORKSPACE b/WORKSPACE
-+index 2db3c5db2f..60582d1a0f 100644
-+--- a/WORKSPACE
-++++ b/WORKSPACE
-+@@ -20,7 +20,7 @@ register_toolchains(
-+
-+ git_repository(
-+ name = "io_bazel_rules_python",
-+- commit = "8b5d0683a7d878b28fffe464779c8a53659fc645",
-++ commit = "fdbb17a4118a1728d19e638a5291b4c4266ea5b8",
-+ remote = "https://github.com/bazelbuild/rules_python.git",
-+ )
-+
-+diff --git a/bazel/generate_cc.bzl b/bazel/generate_cc.bzl
-+index b7edcda702..581165a190 100644
-+--- a/bazel/generate_cc.bzl
-++++ b/bazel/generate_cc.bzl
-+@@ -41,11 +41,11 @@ def _join_directories(directories):
-+
-+ def generate_cc_impl(ctx):
-+ """Implementation of the generate_cc rule."""
-+- protos = [f for src in ctx.attr.srcs for f in src.proto.check_deps_sources.to_list()]
-++ protos = [f for src in ctx.attr.srcs for f in src[ProtoInfo].check_deps_sources.to_list()]
-+ includes = [
-+ f
-+ for src in ctx.attr.srcs
-+- for f in src.proto.transitive_imports.to_list()
-++ for f in src[ProtoInfo].transitive_imports.to_list()
-+ ]
-+ outs = []
-+ proto_root = get_proto_root(
-+diff --git a/bazel/python_rules.bzl b/bazel/python_rules.bzl
-+index 17004f3474..3df30f8262 100644
-+--- a/bazel/python_rules.bzl
-++++ b/bazel/python_rules.bzl
-+@@ -28,12 +28,12 @@ def _get_staged_proto_file(context, source_file):
-+ def _generate_py_impl(context):
-+ protos = []
-+ for src in context.attr.deps:
-+- for file in src.proto.direct_sources:
-++ for file in src[ProtoInfo].direct_sources:
-+ protos.append(_get_staged_proto_file(context, file))
-+ includes = [
-+ file
-+ for src in context.attr.deps
-+- for file in src.proto.transitive_imports.to_list()
-++ for file in src[ProtoInfo].transitive_imports.to_list()
-+ ]
-+ proto_root = get_proto_root(context.label.workspace_root)
-+ format_str = (_GENERATED_GRPC_PROTO_FORMAT if context.executable.plugin else _GENERATED_PROTO_FORMAT)
-diff --git a/bazel/grpc-protoinfo-2.patch b/bazel/grpc-protoinfo-2.patch
-new file mode 100644
-index 000000000..f1d62d8aa
---- /dev/null
-+++ b/bazel/grpc-protoinfo-2.patch
-@@ -0,0 +1,32 @@
-+commit ecf04ccf4d8be9378166ec9e0ccf44081e211d11
-+Author: Marcel Hlopko <hlopko@google.com>
-+Date: Thu Jun 20 18:57:33 2019 +0200
-+
-+ Require ProtoInfo in attributes, not "proto"
-+
-+diff --git a/bazel/generate_cc.bzl b/bazel/generate_cc.bzl
-+index 581165a190..87e8b9d329 100644
-+--- a/bazel/generate_cc.bzl
-++++ b/bazel/generate_cc.bzl
-+@@ -146,7 +146,7 @@ _generate_cc = rule(
-+ "srcs": attr.label_list(
-+ mandatory = True,
-+ allow_empty = False,
-+- providers = ["proto"],
-++ providers = [ProtoInfo],
-+ ),
-+ "plugin": attr.label(
-+ executable = True,
-+diff --git a/bazel/python_rules.bzl b/bazel/python_rules.bzl
-+index 3df30f8262..d4ff77094c 100644
-+--- a/bazel/python_rules.bzl
-++++ b/bazel/python_rules.bzl
-+@@ -99,7 +99,7 @@ __generate_py = rule(
-+ "deps": attr.label_list(
-+ mandatory = True,
-+ allow_empty = False,
-+- providers = ["proto"],
-++ providers = [ProtoInfo],
-+ ),
-+ "plugin": attr.label(
-+ executable = True,
-diff --git a/bazel/grpc-protoinfo-3.patch b/bazel/grpc-protoinfo-3.patch
-new file mode 100644
-index 000000000..97eab476f
---- /dev/null
-+++ b/bazel/grpc-protoinfo-3.patch
-@@ -0,0 +1,31 @@
-+commit e2ba3aa07009292617c3cabe734e8e44099b22ac
-+Author: Lukacs T. Berki <lberki@google.com>
-+Date: Tue Aug 6 14:00:11 2019 +0200
-+
-+ Update C++ code generation to work with Bazel 0.29 .
-+
-+ The above Bazel version changes proto compilation slightly: some proto
-+ files are put into a `_virtual_imports` directory and thus
-+ `_get_include_directory` needs to be updated accordingly.
-+
-+ Ideally, it would use instead the `ProtoInfo` provider to tease out the
-+ proto import directories, but that's a bit more intrusive change.
-+
-+diff --git a/bazel/protobuf.bzl b/bazel/protobuf.bzl
-+index f2df7bd87b..3066e1d550 100644
-+--- a/bazel/protobuf.bzl
-++++ b/bazel/protobuf.bzl
-+@@ -59,6 +59,13 @@ def proto_path_to_generated_filename(proto_path, fmt_str):
-+ def _get_include_directory(include):
-+ directory = include.path
-+ prefix_len = 0
-++
-++ virtual_imports = "/_virtual_imports/"
-++ if not include.is_source and virtual_imports in include.path:
-++ root, relative = include.path.split(virtual_imports, 2)
-++ result = root + virtual_imports + relative.split("/", 1)[0]
-++ return result
-++
-+ if not include.is_source and directory.startswith(include.root.path):
-+ prefix_len = len(include.root.path) + 1
-+
-diff --git a/bazel/repositories.bzl b/bazel/repositories.bzl
-index c0b2205e0..d0df39d54 100644
---- a/bazel/repositories.bzl
-+++ b/bazel/repositories.bzl
-@@ -600,7 +600,17 @@ def _com_googlesource_quiche():
- )
-
- def _com_github_grpc_grpc():
-- _repository_impl("com_github_grpc_grpc")
-+ _repository_impl(
-+ "com_github_grpc_grpc",
-+ patches = [
-+ # Workaround for https://github.com/envoyproxy/envoy/issues/7863
-+ "@envoy//bazel:grpc-protoinfo-1.patch",
-+ "@envoy//bazel:grpc-protoinfo-2.patch",
-+ # Pre-integration of https://github.com/grpc/grpc/pull/19860
-+ "@envoy//bazel:grpc-protoinfo-3.patch",
-+ ],
-+ patch_args = ["-p1"],
-+ )
-
- # Rebind some stuff to match what the gRPC Bazel is expecting.
- native.bind(
---
-2.23.0
-
diff --git a/0002-bazel-patch-gRPC-to-fix-Envoy-builds-with-glibc-v2.3.patch b/0002-bazel-patch-gRPC-to-fix-Envoy-builds-with-glibc-v2.3.patch
deleted file mode 100644
index bdb4ae349093..000000000000
--- a/0002-bazel-patch-gRPC-to-fix-Envoy-builds-with-glibc-v2.3.patch
+++ /dev/null
@@ -1,124 +0,0 @@
-From d99e7f6a8ddebe6cfbe0afd0cf9056137d9ee6ae Mon Sep 17 00:00:00 2001
-From: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com>
-Date: Wed, 28 Aug 2019 02:41:20 +0300
-Subject: [PATCH] bazel: patch gRPC to fix Envoy builds with glibc v2.30
- (#7971)
-
-Description: the latest glibc (v2.30) declares its own `gettid()` function (see [0]) and this creates a naming conflict in gRPC which has a function with the same name.
-
-Apply to gRPC [a patch](https://github.com/grpc/grpc/pull/18950) which renames `gettid()` to `sys_gettid()`.
-
-[0] https://sourceware.org/git/?p=glibc.git;a=commit;h=1d0fc213824eaa2a8f8c4385daaa698ee8fb7c92
-
-Risk Level: low
-Testing: unit tests
-Docs Changes: n/a
-Release Notes: n/a
-
-Signed-off-by: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com>
----
- bazel/grpc-rename-gettid.patch | 78 ++++++++++++++++++++++++++++++++++
- bazel/repositories.bzl | 2 +
- 2 files changed, 80 insertions(+)
- create mode 100644 bazel/grpc-rename-gettid.patch
-
-diff --git a/bazel/grpc-rename-gettid.patch b/bazel/grpc-rename-gettid.patch
-new file mode 100644
-index 000000000..90bd91158
---- /dev/null
-+++ b/bazel/grpc-rename-gettid.patch
-@@ -0,0 +1,78 @@
-+From d1d017390b799c59d6fdf7b8afa6136d218bdd61 Mon Sep 17 00:00:00 2001
-+From: Benjamin Peterson <benjamin@dropbox.com>
-+Date: Fri, 3 May 2019 08:11:00 -0700
-+Subject: [PATCH] Rename gettid() functions.
-+
-+glibc 2.30 will declare its own gettid; see https://sourceware.org/git/?p=glibc.git;a=commit;h=1d0fc213824eaa2a8f8c4385daaa698ee8fb7c92. Rename the grpc versions to avoid naming conflicts.
-+---
-+ src/core/lib/gpr/log_linux.cc | 4 ++--
-+ src/core/lib/gpr/log_posix.cc | 4 ++--
-+ src/core/lib/iomgr/ev_epollex_linux.cc | 4 ++--
-+ 3 files changed, 6 insertions(+), 6 deletions(-)
-+
-+diff --git a/src/core/lib/gpr/log_linux.cc b/src/core/lib/gpr/log_linux.cc
-+index 561276f0c20..8b597b4cf2f 100644
-+--- a/src/core/lib/gpr/log_linux.cc
-++++ b/src/core/lib/gpr/log_linux.cc
-+@@ -40,7 +40,7 @@
-+ #include <time.h>
-+ #include <unistd.h>
-+
-+-static long gettid(void) { return syscall(__NR_gettid); }
-++static long sys_gettid(void) { return syscall(__NR_gettid); }
-+
-+ void gpr_log(const char* file, int line, gpr_log_severity severity,
-+ const char* format, ...) {
-+@@ -70,7 +70,7 @@ void gpr_default_log(gpr_log_func_args* args) {
-+ gpr_timespec now = gpr_now(GPR_CLOCK_REALTIME);
-+ struct tm tm;
-+ static __thread long tid = 0;
-+- if (tid == 0) tid = gettid();
-++ if (tid == 0) tid = sys_gettid();
-+
-+ timer = static_cast<time_t>(now.tv_sec);
-+ final_slash = strrchr(args->file, '/');
-+diff --git a/src/core/lib/gpr/log_posix.cc b/src/core/lib/gpr/log_posix.cc
-+index b6edc14ab6b..2f7c6ce3760 100644
-+--- a/src/core/lib/gpr/log_posix.cc
-++++ b/src/core/lib/gpr/log_posix.cc
-+@@ -31,7 +31,7 @@
-+ #include <string.h>
-+ #include <time.h>
-+
-+-static intptr_t gettid(void) { return (intptr_t)pthread_self(); }
-++static intptr_t sys_gettid(void) { return (intptr_t)pthread_self(); }
-+
-+ void gpr_log(const char* file, int line, gpr_log_severity severity,
-+ const char* format, ...) {
-+@@ -86,7 +86,7 @@ void gpr_default_log(gpr_log_func_args* args) {
-+ char* prefix;
-+ gpr_asprintf(&prefix, "%s%s.%09d %7" PRIdPTR " %s:%d]",
-+ gpr_log_severity_string(args->severity), time_buffer,
-+- (int)(now.tv_nsec), gettid(), display_file, args->line);
-++ (int)(now.tv_nsec), sys_gettid(), display_file, args->line);
-+
-+ fprintf(stderr, "%-70s %s\n", prefix, args->message);
-+ gpr_free(prefix);
-+diff --git a/src/core/lib/iomgr/ev_epollex_linux.cc b/src/core/lib/iomgr/ev_epollex_linux.cc
-+index 08116b3ab53..76f59844312 100644
-+--- a/src/core/lib/iomgr/ev_epollex_linux.cc
-++++ b/src/core/lib/iomgr/ev_epollex_linux.cc
-+@@ -1102,7 +1102,7 @@ static void end_worker(grpc_pollset* pollset, grpc_pollset_worker* worker,
-+ }
-+
-+ #ifndef NDEBUG
-+-static long gettid(void) { return syscall(__NR_gettid); }
-++static long sys_gettid(void) { return syscall(__NR_gettid); }
-+ #endif
-+
-+ /* pollset->mu lock must be held by the caller before calling this.
-+@@ -1122,7 +1122,7 @@ static grpc_error* pollset_work(grpc_pollset* pollset,
-+ #define WORKER_PTR (&worker)
-+ #endif
-+ #ifndef NDEBUG
-+- WORKER_PTR->originator = gettid();
-++ WORKER_PTR->originator = sys_gettid();
-+ #endif
-+ if (GRPC_TRACE_FLAG_ENABLED(grpc_polling_trace)) {
-+ gpr_log(GPR_INFO,
-diff --git a/bazel/repositories.bzl b/bazel/repositories.bzl
-index 15dbd7cb0..b80d6f0bf 100644
---- a/bazel/repositories.bzl
-+++ b/bazel/repositories.bzl
-@@ -617,6 +617,8 @@ def _com_github_grpc_grpc():
- "@envoy//bazel:grpc-protoinfo-2.patch",
- # Pre-integration of https://github.com/grpc/grpc/pull/19860
- "@envoy//bazel:grpc-protoinfo-3.patch",
-+ # Pre-integration of https://github.com/grpc/grpc/pull/18950
-+ "@envoy//bazel:grpc-rename-gettid.patch",
- ],
- patch_args = ["-p1"],
- )
---
-2.23.0
-
diff --git a/0003-fix-com_github_datadog_dd_opentracing_cpp-build-fail.patch b/0003-fix-com_github_datadog_dd_opentracing_cpp-build-fail.patch
deleted file mode 100644
index 659985350ed3..000000000000
--- a/0003-fix-com_github_datadog_dd_opentracing_cpp-build-fail.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-From f9bc4273bad0ecfb291169a88e6c632d69f646ab Mon Sep 17 00:00:00 2001
-From: kXuan <kxuanobj@gmail.com>
-Date: Thu, 18 Jul 2019 18:17:22 +0800
-Subject: [PATCH] fix com_github_datadog_dd_opentracing_cpp build failed on gcc
- 9
-
-Signed-off-by: kXuan <kxuanobj@gmail.com>
----
- bazel/dd-opentracing-cpp.patch | 26 ++++++++++++++++++++++++++
- bazel/repositories.bzl | 6 +++++-
- 2 files changed, 31 insertions(+), 1 deletion(-)
- create mode 100644 bazel/dd-opentracing-cpp.patch
-
-diff --git a/bazel/dd-opentracing-cpp.patch b/bazel/dd-opentracing-cpp.patch
-new file mode 100644
-index 000000000..227719c7d
---- /dev/null
-+++ b/bazel/dd-opentracing-cpp.patch
-@@ -0,0 +1,26 @@
-+From ea704f38430f69b6cfdcc2bb1516e65b236bc4cf Mon Sep 17 00:00:00 2001
-+From: Yuval Kohavi <yuval.kohavi@gmail.com>
-+Date: Thu, 2 May 2019 18:23:02 -0400
-+Subject: [PATCH] remove redundant move (#94)
-+
-+gcc 9 reports this move as redundant
-+---
-+ src/tracer.cpp | 2 +-
-+ 1 file changed, 1 insertion(+), 1 deletion(-)
-+
-+diff --git a/src/tracer.cpp b/src/tracer.cpp
-+index 99befe8..0bd9f0e 100644
-+--- a/src/tracer.cpp
-++++ b/src/tracer.cpp
-+@@ -100,7 +100,7 @@ std::unique_ptr<ot::Span> Tracer::StartSpanWithOptions(ot::string_view operation
-+ if (is_trace_root && opts_.environment != "") {
-+ span->SetTag(tags::environment, opts_.environment);
-+ }
-+- return std::move(span);
-++ return span;
-+ } catch (const std::bad_alloc &) {
-+ // At least don't crash.
-+ return nullptr;
-+--
-+2.22.0
-+
-diff --git a/bazel/repositories.bzl b/bazel/repositories.bzl
-index 1c0e6abb5..0f227817b 100644
---- a/bazel/repositories.bzl
-+++ b/bazel/repositories.bzl
-@@ -344,7 +344,11 @@ def _com_lightstep_tracer_cpp():
- )
-
- def _com_github_datadog_dd_opentracing_cpp():
-- _repository_impl("com_github_datadog_dd_opentracing_cpp")
-+ _repository_impl(
-+ "com_github_datadog_dd_opentracing_cpp",
-+ patch_args = ["-p1"],
-+ patches = ["@envoy//bazel:dd-opentracing-cpp.patch"]
-+ )
- _repository_impl(
- name = "com_github_msgpack_msgpack_c",
- build_file = "@com_github_datadog_dd_opentracing_cpp//:bazel/external/msgpack.BUILD",
---
-2.22.0
-
diff --git a/PKGBUILD b/PKGBUILD
index e7475751f48d..dc68521de86e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ prepare() {
# done
go get github.com/bazelbuild/buildtools/buildifier
# The commit id of $pkgver
- echo "7a12f379e47a9f7cf7211c727fe8fc70b6a0a9ab" > SOURCE_VERSION
+ echo "44f8c365a1f1798f0af776f6aa64279dc68f5666" > SOURCE_VERSION
}
build() {