summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKnut Ahlers2018-12-28 12:38:00 +0100
committerKnut Ahlers2018-12-28 12:38:00 +0100
commit205c17a2d905ae414f56d49ebbf44d251918d198 (patch)
tree26f119df4f1b65c93810ec44a298cd75bf1d3a3f
parent0ae21aa7fb2de2e19d5c167abb256709681380d4 (diff)
downloadaur-205c17a2d905ae414f56d49ebbf44d251918d198.tar.gz
Add auto-update script
Signed-off-by: Knut Ahlers <knut@ahlers.me>
-rwxr-xr-xupdate_version.sh34
1 files changed, 34 insertions, 0 deletions
diff --git a/update_version.sh b/update_version.sh
new file mode 100755
index 000000000000..2c2ba1ad8dab
--- /dev/null
+++ b/update_version.sh
@@ -0,0 +1,34 @@
+#!/bin/bash
+set -euxo pipefail
+
+# Read pkg name
+PKG=$(awk -F '=' '/pkgname=/{ print $2 }' PKGBUILD)
+
+# Get latest version
+VER=$(curl -sSfL "https://lv.luzifer.io/catalog-api/envrun/latest.txt?p=version")
+
+# Insert latest version into PKGBUILD
+sed -i \
+ -e "s/^pkgver=.*/pkgver=${VER}/" \
+ PKGBUILD
+
+# Check whether this changed anything
+if (git diff --exit-code PKGBUILD); then
+ echo "Package ${PKG} has most recent version ${VER}"
+ exit 0
+fi
+
+# Reset pkgrel
+sed -i \
+ -e 's/pkgrel=.*/pkgrel=1/' \
+ PKGBUILD
+
+# Update source hashes
+updpkgsums
+
+# Update .SRCINFO
+makepkg --printsrcinfo >.SRCINFO
+
+# Commit changes
+git add PKGBUILD .SRCINFO
+git commit -m "${PKG} v${VER}"