summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Peres2015-07-18 21:09:26 +0300
committerMartin Peres2015-07-18 21:09:26 +0300
commit4dffb3c45a8c5f7b01870053f7d0e4dae6cfd62a (patch)
treeba7d4e4dafcea2947f9f19e87c4f7da577cb0710
downloadaur-4dffb3c45a8c5f7b01870053f7d0e4dae6cfd62a.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD45
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83c7bbb16fde
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = envytools-git
+ pkgdesc = A tool for nouveau debugging
+ pkgver = 0.r4044.3b4bd3e
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/envytools/envytools
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ makedepends = cython
+ depends = python
+ depends = libpciaccess
+ depends = libxml2
+ depends = libvdpau
+ options = staticlibs
+ source = envytools-git::git+https://github.com/envytools/envytools.git
+ sha256sums = SKIP
+
+pkgname = envytools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43d7646b2e94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Martin Peres < martin DOT peres AT free DOT fr>
+# Contributor: Timothée Ravier <tim@siosm.fr>
+
+pkgname=envytools-git
+pkgver=0.r4044.3b4bd3e
+pkgrel=1
+epoch=1
+pkgdesc="A tool for nouveau debugging"
+arch=('i686' 'x86_64')
+url='https://github.com/envytools/envytools'
+license=('GPL')
+makedepends=('git' 'cmake' 'cython')
+options=('staticlibs')
+depends=('python' 'libpciaccess' 'libxml2' 'libvdpau')
+source=("${pkgname}::git+https://github.com/envytools/envytools.git")
+sha256sums=('SKIP')
+
+prepare() {
+ msg "Cleaning the previous build directory..."
+ rm -rf build
+ mkdir build
+}
+
+pkgver() {
+ cd ${pkgname}
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd build
+ nvapy_install_path=`python -c "import site; print(site.getsitepackages()[0])"`
+ msg "Will install the nvapy lib in ${nvapy_install_path}"
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DNVAPY_PATH=${nvapy_install_path} \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ ../${pkgname}
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et: