summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukáš Jirkovský2016-11-30 21:12:09 +0100
committerLukáš Jirkovský2016-11-30 21:12:09 +0100
commitc2604b16845e3d7eb93bdf1380d8ea450d85dbcd (patch)
treee500fdd3719ad9f2693eef1b168e402a66c00a65
downloadaur-c2604b16845e3d7eb93bdf1380d8ea450d85dbcd.tar.gz
initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc6f8d5ec540
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Wed Nov 30 20:12:09 UTC 2016
+pkgbase = eos_portable_archive
+ pkgdesc = A portable binary archive to be used with boost::serialization
+ pkgver = 5.1
+ pkgrel = 1
+ url = https://epa.codeplex.com/
+ arch = any
+ license = custom
+ depends = boost
+ source = eos_portable_archive_v5.1.zip::http://download-codeplex.sec.s-msft.com/Download/Release?ProjectName=epa&DownloadId=1510504&FileTime=130914061641930000&Build=21031
+ md5sums = d2deb35c23e5b4e4468f00c3d9d2f7b3
+
+pkgname = eos_portable_archive
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..720265345b9a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+pkgname=eos_portable_archive
+pkgver=5.1
+pkgrel=1
+pkgdesc="A portable binary archive to be used with boost::serialization"
+arch=('any')
+url="https://epa.codeplex.com/"
+license=('custom')
+depends=('boost')
+source=("${pkgname}_v${pkgver}.zip::http://download-codeplex.sec.s-msft.com/Download/Release?ProjectName=epa&DownloadId=1510504&FileTime=130914061641930000&Build=21031")
+md5sums=('d2deb35c23e5b4e4468f00c3d9d2f7b3')
+
+package() {
+ cd "$pkgname"
+ install -d -m755 "$pkgdir/usr/include/eos"
+ install -m644 eos/* "$pkgdir/usr/include/eos/"
+
+ # copy boost license from filesystem
+ install -D -m644 /usr/share/licenses/boost/* "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}